GPS stopped working

This is madness! Jolla should say something about XA2 and the GPS that SUCKS. 1h of biking today and GPS was searching all the time, with no luck. If You want customers that PAY, You should not treat them like trash.

For me it works sometimes after 5-10 minutes, but most of the time it takes 30+ minutes to “lock” GPS. Restarts, different setting, recommended setting - still bad! My Jolla1, without a SIM card, needs ~5 minutes to lock GPS signal! Someone should make a clear statement about that is going on. Is it SOA#1 for everyone from Jolla? Don’t you see a problem here? Is this how “supported device” looks like? Should users debug those issues? If yes, at least WORK with them.

Sailfish OS 4.1
Xperia XA2
4.1.0.24

5 Likes

Me too, on an XA2 dual sim I have to start GPS Info before other apps can use GPS.
So the question is, what does GPSInfo have that other apps don’t.

Nothing I’m aware of. It’s just you can see what’s happening with the GPS satellites in GPSInfo. I think if you left any application running that uses GPS you would get the same result.

Some tests with my 2 XA2 plus.
Config: same on both. Set to ‘High precision’ in location parameters. No mls data. No SUPL server set in gps.conf
One of the 2 XA2 was off for at least two weaks: got a fix on both in less than 1 minute.
Attached a photo of GPS test running on both


The only diffrence between the two XA2 plus is that the one on the right has fallen during an accident and I had to remove the metal part on top of the phone. You can see that the reception level is much better on that one. Is it the problem of XA2?

3 Likes

Okay. It’s work. Got lock within 3 minutes.

Did you get a lock or just an approximate location? What app were you using?

I don’t know what it depends on, on my XA2 the GPS fix is there within 5 minutes or it takes almost an hour.
I can not determine the conditions for this.
So GPS is not usable at the moment because there is no reliable time to GPS fix.
For me also only the recommended settings work, all other does not lead to success.

Greetings
Steffen

Hi,

I’m a new Sailfish OS user and after my first install (XA2 H3113) i see that GPS is not working on any apps (PureMaps or any Android Apps).

I tried with an without SIM, GPSInfo display 0/0 Satellite, what can i do ?

What can you do? Other than read through this thread there’s nothing else you can do that I am aware of other than pester Jolla for a solution.

It’s a known issue with the XA2. There’s been plenty of theories as to why but as far as I know there is no solution yet.

The fact that the GPS works on the XA2 when running Android OS suggests to me it is a problem with Sailfish. We desperately need a solution. For me the GPS functionality is very important and that issue coupled with the lack of Bluetooth functionality with Alien Dalvik is probably going to force me to leave Sailfish.

Sadly there has been total radio silence from Jolla.

1 Like

Hello, try the following:
As preparation:

GPSinfo (Sailfish app) installed from the Jolla Store.
Positioning (Your Location) installed from the Jolla Store.

Activated the following settings on the phone:
    Settings > System > Location > Custom settings: ON
    Select Settings > System > Location > Custom settings:
        GPS location: ON
        Offline position lock: ON
        Online position lock: OFF

The phone should have a clear view of the sky. The first GPS fix can take a long time. In my case it took an hour.

I made an interesting observation. If I activate GPS once a day until the GPS fix, then (so far) it takes a maximum of 5 minutes until the GPS fix.
I continue to observe.

1 Like

Hi,

Thanks @OhneZ for your help, i tried this configuration, nothing is happening after one hour … i’m still keeping 0/0 satellite.

I am sorry but i’m reading the topic and i must say something about all of this …

Firstly i am not going to count clouds and birds in the sky before enabling a GPS, we are in 2021 and most of devices with GPS (even cheap products) are working with or without clear sky, to me it’s like telling me “with Sailfish OS the phone become a sundial so wait for the sun to get the time on your phone”.

To me there is a difference between a prototype on which we do experiments and improvements and a sold functionnal product that fits daily life needs. Why Jolla is selling a licence for this device and present it as “supported device” ? I paid a licence, if we pay for a supported device, we expect to get something reliable and not a prototype.

Secondly i am not going to wait 5 or 30 minutes to start my GPS like starting an old car before taking the road, … this is not a solution, this is not compatible with daily life, imagine each time you need location you have to wait and loose time … we are in 2021 ! please ! what is the next step ? someone is going to strap a compass on the screen to get the north ? or i don’t know … maybe we could get a proper fix for a paid product ?

I’m completely agree with @AlanBreen and other people on this topic. I’m repeating it but we paid a licence for a “supported device” and i see a topic opened for two years without an official fix. It’s clearly false advertising and XA2 should be removed from supported device list after 10 month with the same issue.

This issue with GPS wasn’t properly presented on the website and should be, because i lost money by choosing to buy an XA2 and a licence instead of a classic Androïd phone.

People like me should get a refund for the licence because GPS is a critical feature on a smartphone.

Sorry but i’m very disappointed about my first experience with Sailfish OS.

What else could i do ? Maybe a reinstall ? Is it possible to restore the original Android ROM ?

3 Likes

You can reflash the Android OS. Here’s one how to; https://www.androidinfotech.com/sony-xperia-xa2-xa2-ultra-xa2-plus-oreo/

1 Like

FWI: GPS consistently does work within a few minutes on my XA2. So it’s not totally broken. I concur, it still isn’t as good as it should be, and Jolla should at least be more communicative on the situation. Then again, they rarely comment on any issue, unless they’ve already solved it.

@Jolla: if a reflash to a newer AOSP-base is what’s needed to get GPS working, because of some Qualcomm f#ck-up, then so be it. I’d be happy to wave my fist in anger at Qualcomm again. (And if not for GPS, than for full 64-bit support)

1 Like

This is, unfortunately, not unusual. There are quite a few things in Sailfish that are missing, somewhat flaky or unreliable (VoLTE, exchange email synchronisation, audio in phone calls, GPS, bluetooth connection visibility, calendar entries displaying wrong times, browser issues with popup widows, loss of network connection, etc) either across the board, on specific phone models or in specific cases. Some issues have been outstanding for years, One day I hope to use Sailfish as my daily driver, but that is not today as the OS is simply not mature or reliable enough for me. So I continue to use my iPhone as a daily driver and enjoy using Sailfish as a hobby OS on my XA2 just to play with. I agree with the views about paid licences for Sailfish X. They don’t sell Sailfish in the UK, but if they did (speaking as a legal adviser in UK contract law) the current way in which they are promoting the product (i.e. as a mobile OS alternative to the dominating consumer OS’s of Android and IOS) would almost certainly fall foul of Section 9 the Consumer Rights Act 2015 on fitness for purpose (i.e. there will be reasonable expectations about what a mobile phone should be able to do reliably in 2021 and products sold as such have to meet these expectations unless they are explicitly specified otherwise). There is much similar EU legislation in this area as well. If Jolla ever decide to seriously concentrate their efforts on commercial markets other than Russia then, in whatever manner, and by whatever means, they will need to up their game. Until then we will just have to be ‘grateful receivers’ of Sailfish as it is.

1 Like

Hello,
but I am surprised. after I downloaded the positioning file “Western Europa” and after restarting the phone, I was immediately shown at least 12 satellites. The first fix for 5 of these satellites took an hour.

Of course it is not timely that a fix takes 5 minutes or more. But the navigation system in my car without Google, i.e. pure GPS, takes just as long after a cold start. Since one drives already times 15 minutes without Navi. that happens however fortunately only with battery exchange.
I went to Sailfish, because I wanted to get away from the Google crap and IOS garbage. which has also worked 100%. That then functions (GPS fix) take longer, I can deal with. But that is each his personal decision.

Of course, such functions should work stably.

Hi @OhneZ ,

At least smetimes your GPS work ahah !

To me Sailfish was like you the opportunity to look to an independent project out of Google/Apple field too. With this issue we all see that an european and independant OS project must be an european and independant hardware project too. With firmware and hardware dependency we have the hand tied and can’t use innovative project as we want.

Is working with Sony smartphones a good idea ?

Maybe we should have in Europe a true “open hardware” smartphone with open source firmware easy to adapt for all companies / communities who want to build smartphone OS. Sailfish deserve that, this project is too good to be such wasted by this kind of firmware issue and what is more with open hardware developers might be able to focus more on quality and innovation than trying to adapt constantly the OS to close and complicated firmwares. Project like Sailfish can’t be competitive to Google/Apple in such conditions.

I came from an other project that i was testing for many month with Samsung Devices, it’s /e/ OS, an interesting degoogled custom ROM on which i had more stability (only tested with Samsung devices).

The XA2 is in supported devices list too, i think i will come back to this project until a fix is published for Sailfish OS (i asked Jolla support for a refund i hope they will refund me because this issue with GPS is too critical for a smartphone)

ok! i have an odd, very long, quite boring story to tell. GPS problem, but i honestly cannot tell if hw or sw.

it seems that some LCD screens completely block the gps signal…but only in SFOS.
all my fake/knock-off LCD screens work fine, but two of my Sony factory screens do not.

im not talking about time to fix, or MLS, just pure device GPS signal,
as determined by the GPS Info app showing “satellites in view/use: 0/0”, in device-mode-only.

i have three xperia x compacts.
one works perfectly, one is brand new and the gps doesnt work, and the other works with some LCDs and not others.

note: as far as i know, the back inner housing in the xperia x compact is where the GPS antenna is, like the X/XA2/etc.
removing the housing greatly DECREASES the gps signal, but does not eliminate it entirely, so part of the antenna must be in the motherboard.
the front-housing and LCD screen have shit to do with GPS, afaict.

  1. gps always works. satellites found. reflashing, replacing the screen, replacing the housing, continues to work.
    current housing actually has a clean break on GPS antenna, at the bottom.
    still works.
    REMOVING the screen and the housing, bare motherboard, VNC-ing into the device over wifi:
    it STILL finds satellites, tho it did not get a fix any more.

  2. brand new phone. GPS worked fine in android for initial test in google maps (no sim card).
    gps will not locate a single satellite, ever, in SFOS.
    tried reflashing, several OS versions, including the same images that work on phone#1
    did NOT try hardware solutions, since its brand new and works in android.

  3. gps doesnt work with some screens
    screen broke, so replaced it with a screen that i am reasonably certain is a sony factory screen.
    GPS stopped working, zero satellites found ever.
    figured i damaged the antenna, so i replaced the back housing. no luck.
    put the broken screen back on, suddenly found a satellite.
    tried several old screens, two fakes, one legit but cracked.
    all screens work, except the color-accurate, unscratched official one i want to use.
    removing the housing (and thus the GPS antenna) with a good screen, it STILL finds some satellites, tho it does not get a fix.
    removing the housing with the bad screen, it of course still doesnt find any satellites

the front-housing has some contact points, but all the screens all have the same contact points and no visible differences.

3 Likes

I am almost tempted to replace the screen with a Chinese one to see if GPS reception improves.

heh, thats what i had to do, but for me it was literally zero GPS signal with the other screens, not just poor reception. i really dont like the fake screen either, the color reproduction is slightly off, and its much more dim

This is my question and my frustration too. My husband and I need a good satnav. That’s MagicEarth for us (could be PureMaps though). On my XA2+ GPS doesn’t work. On Jolla 1 it did with Here, but now the XA2 with Sailfish is becoming more and more a toy instead of a useful tool. Even in my city ‘Maps’ doesn’t work because it can’t find my location, nor a route. How can I recommend Sailfish to others when GPS doesn’t work?
I also have an Gigaset GS290 with E/OS, out of curiosity. The GPS and satnav (MagicEarth) work fine even without a sim. How is it possible that the XA2 does not work with a sim? I love Sailfish, but two things annoy me very much: the lack of GPS and the tricky new menu of answering a phone call.
My suggestion would be (said before in other topics) to coöperate with a European company like Fairphone or Gigaset and to build up a decent system. As is is now, it cannot last.

1 Like