GPS stopped working

Ans I have to add this as a third annoyance: Sailfish radio apps do stutter, while FDroid radio apps don’t. Also search in Sailfish radio apps became impossible, while it worked on Jolla 1 some years ago. This is no good.

Hi Kea,

I share your point of view about an european solution.

This is not a solution to fix the GPS on Sailfish but i can share what happened in the end for me : because of this gps issue i asked and got a refund for the Sailfish OS licence (i just contacted the support and they did the refund) and then, i replaced Sailfish with /e/ OS and now everything is working fine on XA2 with Magic Earth.

I hope that every people having this issue might get a refund too.

Strange that GPS/MagicEarth works well on an XA2 with E/OS and that it also works well on a Sony 10 II with Sailfish, but not on an XA2 with Sailfish.
I would have gone to E/OS if I didn’t liked Sailfish so much. E is rather dull while Sailfish still has this Finnish design and local apps too. Community devs have done a good job. Some apps I use daily: Nednieuws, Welkweer, Talefish etc. Also Piepmatz is a lot better than Twidere. Sigh, we can’t have it all.

1 Like

I have the same problem as everyone else here. :frowning:

Model: XA2
Sailfish version: 4.1.0.24
Positioning package from Jolla Store installed: Yes
Settings: Recommended settings (Mozilla offline positioning)

I usually have 20-30 satellites in sight in GPSinfo, but I get no fix for extended amounts of time (or none at all). Never indoors, not under trees, not in the car. But sometimes after a long time under clear sky.

My XA2 still has positioning issues, none of the Sailfish updates have resolved the issue.
What is causing the problems?
Can we contact someone that works for Jolla to answer us?
Even if they tell us they don’t know why it’s happening at least that’s better than silence on this issue

2 Likes

I lost all my hopes that Jolla’s eventually fixing this issue. This lasts now for several OS updates - beyond the provisioning of offline MLS data as a replacement of Mozillas online service - without any improvement for the XA2.

Either Jolla cannot fix it, or they don’t want to fix it. At least I would expect some kind of statement if there’s room for improvement and if they plan to work on it.

3 Likes

Hello,
was there ever a working OS version where GPS ran stable ? I read 3.x.x should have run stable.
The question is what has changed since then ?
And of course Jolla should at least give an answer, even if we don’t like it.

My workaround since now almost 2 weeks is, I start once a day GPS info. On the first day the fix took almost 45 minutes. After that, the daily fix went much faster < 3 minutes.
When I have at least 8 satellites I turn it off.
Since then, the fix for the Navi works.
But if you forget to do the fix once, then the game starts all over again.

But this is of course not a real solution to the problem.

I have an Xperia X as well running the same version of Sailfish. It doesn’t have a sim card in it so cannot use MLS location. I don’t turn it on often but it always gets a GPS fix within 2 or 3 minutes.

The problem is related to the XA2. I don’t think it’s hardware because as far as I know the GPS on the XA2 works OK on Android. I think it’s a problem with the implementation of Sailfish on the XA2 or how Sailfish interacts with the Android “blobs” for the GPS.

It’s as if the GPS forgets all the almanac and or empheris data each time it is closed.

I agree it would be nice, no courteous actually, for Jolla to acknowledge the issue and explain what’s going on and whether/when it will be fixed.

1 Like

It is looking likely that 4.1 broke something on my XA2. The GPS works but crashes every 15 mins or so, usually with no visual indication. It only crashes when it doesn’t have a lock, so if you don’t get a lock in 15 mins, good luck.
Yesterday, I got a lock by putting my phone on the balcony. Went downstairs & to shops and it would not get a lock.
Mostly, deactivating/reactivating via GPSinfo fixes it. This also fixes the compass breaking. Sometimes, GPS needs a reboot.

I daren’t try 4.2 as deactivating GPS reportedly doesn’t work any more. 4.01 with MLS Manager worked by far the best for me – usually got a lock in a few mins.