GPS stopped working

The same happened to my XA2 Ultra dual sim (sfos about four weeks ago. I think there were no updates between gps working and not working. I tried to give it a proper chance and left my phone outside for thirty minutes and it did not get a fix. Hello GPS! and GPSinfo showed no satellites when testing another time.

Edit: gps worked fine for several weeks under sfos

Edit 2: reboot does not help


I’m using XA2 Dual SIM and I need to reboot the phone get GPS working again, if I’ve travelled too far from last location.

I have the same problem since I installed Rokua on my Xperia 10 dual SIM. Neither Pure Maps nor ModRana worked for navigation. Neither app was able to detect the current location. The small GPS icon on the top bar remains dim. Renewed installation of Rokua did not help.


I’ve Xperia X and noticed after upgrade it takes much longer to get find the location. It works but takes several minutes now when outside.


I have noticed similar regression. Previous release worked fine but now the only way to have location available is to keep GPSInfo running all the time. GPS behaves like the initial position fix will not happen if long time has elapsed from previous fix. Maybe GPS firmware is not initialized properly. My device is Xperia XA2 single SIM.

Another problem in location is that sometimes Here can’t show whether to turn right or left because it doesn’t get location for a few seconds. Not good in a city you don’t know. Due to this I’m going to buy an Android phone to use when I really need to have GPS.

Possibly Mozilla changing conditions for its location service is the culprit.
They stopped supporting commercial projects, because of patents held by skyhook holding afaiu.


My phone has been using the device only setting for location for months (not sure whether it is that in English. I mean the settings in settings - location - ‘device only’). Wouldn’t that point to another direction than MLS?

My icon flashes like it’s trying to work, just nothing happens

I’ve found turning wifi on helps getting an initial fix on my location and route.

Wait some minutes and a position fix will come. I guess @mosen is right and this is due to Mozilla location service.

GPS sucks on SFOS since years.
what solves it.for me:

when i do switch on gps from top menu i let situations start gpsinfo app.

here i turn gps off again and on and wait till i can see some satellites …

then only i do start here maps / pure maps

yes, you should nnot be in hurry.


XA2 dual sim. GPS never worked adequtely (eg totally unable to lock under tree cover.
But now doesn’t work at all, as op said.

In gpsinfo (sat view), it quickly (10secs) gets satellites, even with no network, under tree cover.
However it simply does not get a fix, even when it has 12 green sats.

So definitely a sw problem, not a hardware one.

BTW this is the #1 issue in sfos for me at present.


I have an XA2 dual sim as well. What worked for me: I started gpsinfo and put the phone somewhere where it could see the whole sky, where it got a fix, eventually, after a really long time (maybe an hour). After that, when I use GPS regularly, it still takes (too) long, but considerably less time than the first time (I assume because it “remembers” information like orbital elements of the GPS satellites, which it would otherwise get from the internet)

1 Like

One hint: GPS is very sensitive to the time source/clock on the receiver device being off, especially when trying to get a lock.
So do make sure your time is set correctly before trying to debug any issues.

I use from the browser to check.


Enabling automatic time update in the Settings menu will sync the phone to a NTP server whenever you go online, but the problem is that the clock will start to drift immediately. So, either go offline and then online again, or use nephros’ idea (, immediately before enabling GPS. It really helps!

GPS is also close to useless on my XA2 dual sim. My time is correct on the second, so that’s not the reason. I really hope that this will be addressed in the upcoming release.

Sorry for the false alarm…
Below did not help since i had 10 minutes wait for a fix again today.
The occasions where i had near insta-fix yesterday separated by some hours probably happend by chance :confused:

false claim

I feel confident now after 2 days testing that the following is doing some impact.

I get very fast fix on Pro¹ when disabling the first option in location settings UI (High precision) and instead selecting individual settings with all three following options in the corresponding settings tab.

No idea why, but since i got this setting i am back to <1min for location fix.

Ironically I seem to get best result upon XZ2 running rinigus port so NO Android App Support here with no sim but WLAN connection available and starting GPSInfo first:

1 Like

With wifi on it works for me too. But that’s all right now, and doesn’t help if I’m on the road.

Out of the blue sky (a bit cloudy, actually) my gps works again. I had 4g data connection on, started GPSinfo, put gps on and off in GPSinfo and after that gps on from the upper pull menu. It got fix in two minutes. Again no uppdates. Don’t know what helped. Might have been the use of GPSinfo as pawel.spoon earlier suggested (though this time it worked bit differently). Thanks!

1 Like