GPS stopped working

Out of the blue sky (a bit cloudy, actually) my gps works again. I had 4g data connection on, started GPSinfo, put gps on and off in GPSinfo and after that gps on from the upper pull menu. It got fix in two minutes. Again no uppdates. Don’t know what helped. Might have been the use of GPSinfo as pawel.spoon earlier suggested (though this time it worked bit differently). Thanks!

1 Like

Same actually. It’s pretty intermittent; but much better than zero. I’ve also been using GPSinfo and changed my settings mid directions.

Same issue here on my Jolla phone, it takes at least 5 minutes to get a location update even with clear sky on open land.
In a city it takes sometimes even more time.

This is really sad that Jolla is not able to deliver proper functioning location service since years (was better in the past).
My Samsung company phone gets the location update done in seconds, even in city area.

Please Jolla fix this soon, it is too easy to make customers happy or not with the proper functionality of this important feature.

2 Likes

I can confirm that the GPS sucked for years, but it works really fine since the last update to 3.3.0.16 on my Xperia 10 Dual SIM.

My “location” settings are “individual settings”, and then “activate GPS” and NO Mozilla and NO WLAN. I want to strictly avoid any network activity or “help” from other systems like mobile network while testing the GPS receiver. Aditional, I wanted to avoid any disturbing effects caused by possible software incompatibility, not available services and so on.

The result is: After turning on GPS, it needs abt. 50 sec. to get a position fix. Location here is rural area, but in the house. Outside, the position fix comes (felt) 5-10 sec. faster.

I suggest, to test the “real” GPS receiver, switch off all other services regarding position.

2 Likes

I’ll try this and see what happens.

My GPS on Sony XA2 dual sim also went to almost unusable couple of weeks ago. Flashing to Android and back to Sailfish fixed it.

It used to work just fine even after a-gps-support was dropped. Sometimes it took some time to get a lock but only tens of seconds or couple of minutes at worst.

Some times ago I think it just started to get worst and eventually getting a gps lock took maybe 10 minutes or didn’t get a lock at all. Reception was bad and location was lost every now and then. These were on places where gps reception had been fine before. I use gps almost every day and save the tracks so I can compare.

I use Meerun tracker and the reception indicator would show red or yellow in places where it used show maximum signal.

Last weekend I used Sonys Emma-tool to flash the phone back to Android. I used the phone with Android over the weekend and on Monday I restored my Sailfish installation from a backup image. So I didn’t even do an actual factory reset but returned to my working system.

Now GPS is working fine again. It doesn’t take long to get a lock, Meerun shows full signal and signal doesn’t get lost during use.

I’ve had similar experiences with my phone randomly freezing with yellow led blinking. Flashing to Android and back makes a difference at least for some time.

I don’t know what’s going on but I don’t think it’s a coincidence. Of course it would be great someone could confirm this.

Jolla’s own instructions do state that it is important to use the phone with Android with the SIM you’re going to use before flashing to Sailfish.

I accessed the Service Menu while I was on Android and did notice that on some page about GPS it was possible to reset or delete some data. I did do that also. I can’t access Service Menu now to check the exact wording.

Perhaps some auxiliary gps data is loaded in to the actual hardware. So if this doesn’t happen with Sailfish then gps reception would start to deteriorate when this data goes stale. But I’m just guessing.

1 Like

Hardware part sounds bit like feature in Polar sportwatches. Although it seems to be connected to A-GPS and it’s not mentioned where file is stored.

Jolla announced that it’ll drop support for Mozilla location services. I thought this means dropping A-GPS but is it so? Or are those things separate features?

Same issue here on XA2. Update from Jolla would be great.

2 Likes

On my Sony XA2plus dual sim (with only 1sim card) navigation is not possible. In my memory the problems starting in the update before Rokua. I used HereWeGo for years and at first it worked fine. Some time ago I got trouble with GPS: very slow or not working at all. Now I installed MagicEarth, a fine satnav, but ‘no GPS available’. I also have an ipad cellular and there it works fortunately, without WLAN and without mobile network. So it’s not the satnav that causes trouble.
I am not a developer, so my hope is that Jolla can fix this.

2 Likes

Today I did what Andrea777.Fritz suggested. Only ‘adapted’ location, the GPS with device only, and it worked well with MagicEarth. Got GPS fairly quick and navigation.worked… Thank you Andrea777.

3 Likes

hetas: My GPS on Sony XA2 dual sim also went to almost unusable couple of weeks ago. Flashing to Android and back to Sailfish fixed it.

Well that didn’t help for long. Yesterday I started having GPS troubles again. So if this reflashing actually had and effect it lasted about a week.

I’ll try the Android flashing again at some point to see if I’ll have same results or if it was just a fluke.

The same issue appeared for my XA2 dual sim a couple of weeks ago. Getting a position fix takes very long, despite good signal strength (according to GPSinfo). I wonder if it has something to do with the compass sensor: at least for me the compass works very inconsistently.

2 Likes

Xperia 10 here and having the same issues. GPS takes a looong time to get a lock. And it is gradually getting worse. Something is going on here…
Update: Switched off the “High precision” and left only the GPS device setting on and now it works a lot better??

1 Like

Last weekend, a week ago that is, I flashed back to Android and then back to Sailfish again. And it did improve the GPS for while again. Now it’s starting to take a long time to get a lock and the reception is lost during use so there’s gaps in the saved track and the covered distance isn’t accurate.

And I’ve had the total freeze with the amber led twice. So my earlier theory that flashing to Android would help with that seems not to be valid.

So this phone is pretty close to being unusbale. I need a back up phone in case of this XA2 freezes and now I need one for the gps also. It is starting to be too much effort.

2 Likes

I had similar problems with the GPS.

I assume, that there are some incompatibilities or difficulties/bugs between the GPS receiver and the whole system around it on the one side and all the precision location services like Mozilla location service (Mobile Tower data) on the other side. Found also no way to solve this.

So I switched all this extension off using “settings/location service/”:
High accuracy - off
Battery save mode - off
Exclusive mode - on
Individual settings - off

This works on my phone.
This also works:

High accuracy - off
Battery save mode - off
Exclusive mode - off
Individual settings - on,
and then

GPS position fix - on
Mozilla + Mobile network - off
Mozilla + WLAN Hotspots - off

I can confirm that GPS with all other settings does not work, but if it’s done as described above, it should work. Please try and report, I am curious!

3 Likes

I’ve tried the Exclusive mode but it doesn’t seem to make a difference in my case.

2 Likes

For me on my device (XA2) it just does not matter what I have selected. With or without MLS it just takes as long as it takes to download almanach from satellites in view. Under good circumstances it is quite fast, if moved long distance from last position or bad weather or (leaf) roof above it takes longer. Even up to 12 minutes is then possible :frowning:

I do hope that MLS somehow gets (or better; get allowed) to continue the service!
Another question is what Jolla will do in next release 3.4? Will they remove MLS from options? And replace with???

Oh,
and an official statement from Jolla would be appreciated if they are allowed to continue using MLS and/or MLS should be still working on our devices. Or whatever?
Just some clarification, please!!!

5 Likes

Do you know for sure that Mozilla Location Services provide the almanac? My current, mainly guessed, understanding is that a-gps provides the almanac and MLS does not provide a-gps data.

Maybe getting the current approximate location from MLS helps with the position fix I don’t know. But at least according to this map MLS data in my area is so scarce that it wouldn’t do any difference.

But even if it was just down to MLS or just down to a-gps that would not explain why the location fix is lost during use. Location is know at that point.

Of course MLS options in the settings should be removed if they are not used in any way.

EDIT: Ok, I just tried browse for a-gps, again, and my understanding was that a-gps only means that the almanac can be downloaded from the internet. But apparently cell tower or wlan network positioning is also a form of a-gps and does help with getting a position fix quicker.