Geocaching app c:geo stopped working

REPRODUCIBILITY (% or how often): 100%
HARDWARE (Jolla1, Tablet, XA2,…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


I have been using the Android app c:geo for geocaching ( It stopped working after updating to Rokua.


Fresh install of the app.


  1. Launch the app c:geo. The “Getting started” page opens.
  2. Tap “Configure your geocaching platform(s)”. The platform selection opens.
  3. Tap on any of the platform names. The app freezes.


Usable app.


Unusable app.


After closing the app after freezing, it won’t start at all on the next try. Reinstall or “Clear data” fixes the startup-issue, but not the freezing.

The freezing happens also when trying to exit the “About” page byt tapping the back button.

The app has a “Generate logfile” button and I was able to get a few lines there:

[main] External public cgeo directory ‘/storage/emulated/0/cgeo’ not available
[RxCachedThreadScheduler-1] ‘null’ is NOT available as external dir
[RxCachedThreadScheduler-1] Chosen extCgeoDir null is not an available external dir, falling back to default extCgeoDir
[main] ‘null’ is NOT available as external dir
[main] Chosen extCgeoDir null is not an available external dir, falling back to default extCgeoDir
[looper callbacks] Unable to create network location provider: provider doesn’t exist: network

The same behaviour occurs even with old versions of the app, so this is definately a regression. I know the app was working at least in February 2020 and not working anymore in June 2020. The Rokua update was in April 2020.


Don’t have an answer, but wanted to bump, because I’m curious about network location on SFOS. I see ‘battery saving mode’ option in Settings, but don’t get any results. is there any NLP for SF?
I did find ‘libosmscout with geocoder - NLP’ profile in OSM Scout Server, and switched to it, but no fix yet …

@Levone1 see also here

1 Like

I see… I don’t know much about this stuff, but, if that’s true, does that mean there’s no NLP options, (no alternatives to Mozilla)?

There is still Google. And Here? Or other?
I only activated that on Jolla because of Mozilla, no other device had activated this before.
So, maybe worth a question on zendesk to Jolla as after the first week(s) Jolla staff @participation/answering here on this forum is quite quiet!

So either dedicated thread, erm topic, or zendesk!
If MLS is not available we should not have it anymore in next SFOS release 3.4, or?

1 Like

This has been reported in our internal bug tracker for some time already. I did some investigation, and to me it seems it’s not related to GPS fix.

I have the same problem with c:geo. However, I don’t recall when the problem started. Was it after the Rokua update, or after an update of c:geo?

In my memory it was an update of c:geo that caused the problem. Then I thought: OK, there goes another Android app down the drain. Perhaps a greater dependency on GSF than before.

In the meantime I switched to the Geocaching app. It would be interesting to see what happens when an old version of c:geo is installed.

I tried several old versions of c:geo up to some from 2018 and none of them worked.

The Geocaching app is also GSF dependent. I can start the Geocaching app, and I can use it for logging and reading the desriptions of caches etc, but the maps don’t work, which makes it pretty much unusable for geocaching.

I have no problems with the Geocaching app. Mapbox shows me all 5 possible maps. I am a premium member, but I don’t think this matters.

Mapbox also shows up in Whatsapp (share location) and in PureMaps. (Maybe PureMaps gave me the possibility?) I use GPSInfo to secure a GPS fix; probably Android apps don’t trigger the need for a location. I also installed HERE WeGo from Jolla Store, but I doubt that it has any influence here.

Ah yes. PureMaps info says: Require Mapbox GL QML 1.7.0 or higher.

I hope this helps (a bit)!

BTW I do own a Garmin Oregon for the real field action, but I have used the Geocaching app for on-site info, like logs and spoiler photos. The map is responding to the GPS.

1 Like

When I open the Geocaching app I get a white screen with the green banner on top and a green loading icon in the middle of the white. I only get forward by using the back button. Then I get a warning “Something went wrong Please try again.” and the map area is white with a text about Google services not being supported.

I have Pure maps, but not GPSInfo.

Which device are you on? Do you have microg or something like that installed?

I am on XA2, running Rokua. Indeed, MicroG has been installed.

In case you use Whatsapp: in a message you can click the paperclip, and share your location. This is where Mapbox also kicks in on my phone.

OK, so MicroG clearly is the difference in the Geocaching app.

Mapbox works in Whatsapp

I have exactly the same problem. XA2 and MicroG. c:geo was working before the Rokua update. I also tested older versions, to no avail.

The problem happens when trying to set up access to My understanding is that the freeze happens at the point where the app tries to open a browser window for signing in to the service - though I may be misremembering how it used to work. Anyway my theory is that this is unrelated to GPS and could instead be a problem in integration between Android apps and the browser component. I’ve seen similar problems with the Slack app on Rokua.

For me, c:geo stopped working when upgrading to Sailfish, when trying to start c:geo it quietly goes away. Unfortunately Pallas-Yllästunturi update did not make a difference with this. How would one debug this?

@ExTechOp To fix the startup problem, see the OP:

After closing the app after freezing, it won’t start at all on the next try. Reinstall or “Clear data” fixes the startup-issue, but not the freezing.

I think you should be able to make it start up using the “Clear data” method (found under Settings -> Apps -> c:geo). Then it’s the account setup that causes the freeze problem.

I haven’t yet dared to upgrade to 3.4.0 but it would be great to know if it fixes the freeze issue.

I haven’t yet dared to upgrade to 3.4.0 but it would be great to know if it fixes the freeze issue.

Unfortunately 3.4.0 doesn’t seem to fix this issue. Tried the “clear data”, and c:geo again got stuck in the account setup. After that, it goes quietly away until you do “clear data” again.

1 Like

I also upgraded to but it didn’t help.

This issue has been reported to the c:geo project in early August. It seems to me that the best chance of fixing it would be on the c:geo app side, as the community can’t do much about Alien Dalvik misbehaving. I posted some more information there. My main finding is that it’s not a total freeze since you can back out from the frozen state with the Android back button. Thus I suspect this could be a UI bug, where the c:geo app triggers some edge case in the Android emulation layer and the service configuration screen is never properly displayed.

1 Like

There has been some progress on diagnosing the problem, reported in the c:geo GitHub issue linked from the above post. It turns out that the freezes are not permanent - if you wait long enough (several minutes in some cases) the app will continue. It may be possible to use the app after configuring it, but restarts are still a problem. It would help if others experimented with c:geo on SFOS 3.3/3.4 and reported if they can use it and especially if you can figure out the cause of the long freezes.

I tried a new install after the upgrade to No joy, uninstalled again.

@rob_kouw Did you wait long enough? You should get past the freeze, but it may take several minutes.