Google play services on xperia 10 III Sailfish 4.4.0.64

Hi!
Has anyone got the xperia 10 III google play service installed? I mean the script. Same way as 10II.

Just a reminder that MicroG are a great experience, you can even install Play Store with them. Oh, and Aurora Store.

2 Likes

Second MicroG and Aurora store, so far what I need in android apps works, though preference to fdroid apps if needing android.

2 Likes

I have via Google play services on Sailfish 4.1 - #62 by ubuntuscofield - General - Sailfish OS Forum

Alright. I get an error message ./install_opengapps.sh: line 84: rsync: not found when I try to install the script. Any idea what to do? The script worked well on the xperia 10 II

You need to install rsync: pkcon install rsync

Thanks razcampagne it helped.

1 Like

Hi,
do play services and mictog point to the same thing?
thanks

MicroG is a replacement for Google play services, you need signature spoofing for apps to see it as play services. Means apps that need play services can run on custom roms and sailfish, since you are technically not aloud to run Google’s play service ob these.

1 Like

I added microg repo in f-droid and installed microg Core, framework Proxy, fakestore, signature spoofing checker, aurora store on my Xperia 10 III and my android apps works as expected.
https://microg.org/download.html

1 Like

How did you get this working? I’m looking to get this working the old way (without the script above), but somehow I’m stuck…

I made it with the script.

May I ask how? I didn’t know about that script before today. How do I use that? Via Terminal directly on the phone or via PC?
Do I need to install All the micro parts first of US that all done by the script?
And as I have all the parts installed should I better removd them before using the script?
Can I just cooy/paste the complete script to Terminal an run all commands at once?

This is what I did. Google play services on Sailfish 4.1
Download opengapps, opengapps.sh script…

F-droid can be installed from jolla store or f-droid.org
In f-droid app you can add microg repo from settings>repo>+ or you can download the apk needed from microg webpage that also includes repo information Download - microG Project
Install microg Core, framework Proxy, fakestore, signature spoofing checker, aurora store, from f-droid. You can then use aurora store to install android apps.

Is there any particular step you want me to comment on?

I know what and how to download the files (thanx so far) cause I did that several times on XA 2.
So I tried it the same way on 10 III - but without success. So it seems I’m doing something wrong while enabling, that’s where I need a hint.

Try downloading the script either by copy-pasting into a file or from mega, then ‘chmod +x installgapps.sh’ and ‘devel-su ./installgapps.sh’ from terminal when in the same directory, it’s a bit buggy as after reboot the android setup windows keep coming up when you try to swipe away from them, but if you manage to log in it works, even Wild Rift works which is incredible as xiaomi phones are out of luck needing a ‘certified store’, not really a target demographic but still incredible it works on sfos

In f-droid add microG repo. settings>repo>+
Repo: https://microg.org/fdroid/repo
Fingerprint: 9BD06727E62796C0130EB6DAB39B73157451582CBD138E86C468ACC395D14165

Sure, thanks again,so far was clear. It’s all installed, but the following steps don’t work.
I remember on XA 2 we had to enable fake store and otther parts in Android settings, but I can’t find these ootions anywhere. So some settings seem to be missing that notvall stuff needed is enabled. I guess there’s something wrong with system package replacement, but I can’t figure out what.

I couldn’t find that menu as well so i used signature spoof checker to check spoofing.
I think i forgot one step, you need to turn off apk-verification at the android support in settings for spoofing to work.
I think this should be done before installing microG but you can remove all the apps and install them again.
After that you can enable the things you want in that screenshot you posted.