Google calendar doesn't sync automatically

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.3.0
HARDWARE (XA2, X10, X10 II, …): X10 II
UI LANGUAGE: Estonian
REGRESSION: (compared to previous public release: Yes, No, ?): several versions

DESCRIPTION:

Google calendar syncs only when the calendar app is opened or manually.

PRECONDITIONS:

Non gmail Google account with only calendar syncing (all other options are turned off).

STEPS TO REPRODUCE:

  1. Add Google account.
  2. Wait the Google calendar to sync.
  3. Keep waiting.
  4. If you want the calendar to sync open the calendar app or sync manually.

EXPECTED RESULT:

Google calendar would sync automatically at least couple of times a day (or once an hour).

ACTUAL RESULT:

Google calendar doesn’t sync automatically.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

Confirm on XA2.
Google account added, set to only sync the calendar (no Contacts or E-mail), automatically.
It’s never syncing automatically, only when the Calendar app is opened, or when I trigger a sync from the account settings.
Ps: this is not version specific, it has always been like this since I installed Sailfish on the XA2 a year ago.

Problem still there in 4.4.0.58

Thanks for checking this again on 4.4.0. I’ve created an internal issue about it.

I just want to double check to be absolutely certain: the sync works without any obvious error if you perform it manually?

If I open the Calendar app or sync manually then the sync works fine.

Thanks for the clarification. That’s very helpful as it narrows down where the issue may be caused (probably related to buteo-sync-plugins-social, in case that’s of interest).

1 Like