Flatpak on Xperia 10 II - Aarch64

Is it possible to install 64bit Flatpak Support for Aarch64 Devices such as the Xperia 10 II following the instructions on GitHub - sailfishos-flatpak/main: Documentation and issues and simply replace the command to add the repository by
devel-su ssu addrepo rinigus-flatpak http://repo.merproject.org/obs/home:/rinigus:/flatpak/sailfish_latest_aarch64/aarch64/

as rinigus seems to has provided a version for aarch64?
I do not understand what the tbuilder from GitHub - sailfishos-flatpak/tbuilder-project: TBuilder project is for. Why couldn’t I simply use the command
devel-su pkcon install flatpak-runner
?
Has anybody tried to install 64bit flatpak apps?

2 Likes

I tried installing flatpak on a xperia 10 II following the steps described.
pkcon repo-list
shows me that the flatpak package is activated. But
zypper in flatpak-runner
fails finding flatpak runner.
Is it because flatpak-runner is not available at https://sailfishos-flatpak.s3-website.pl-waw.scw.cloud/ anymore?

As indicated above, aarch64 Flatpak is not working - tested on AOSP10/aarch64 based SFOS. However, builds are available at OBS now. See instructions at GitHub - sailfishos-flatpak/main: Documentation and issues and just replace arm repository with aarch64.

1 Like

Okay thanks for the hint.
Is there a terminal command to remove the remove the repository again?
I now have a repo called “flatpak” as shown by pkcon that might be wrong or wont work.
Do I need to add some parameters to
pkcon repo-remove flatpak
as it results in an error

repository identifier and automatic removal required