Flashing of Xperia 10 II fails - getvar secure: FAILED

Hi there,
I tried to flash a new Xperia 10 II (double sim) with official version of latest SFOS using the description in the how-to at jolla.com.

Unlocking works, but flashing fails with following output:

Found XQ-AU52, serial:XXXXXXX, baseband:, bootloader:
Found matching device with serial XXXXXXX
Fastboot command: fastboot -s XXXXXXX

fastboot -s XXXXXXX getvar secure
<< getvar secure: FAILED

fastboot -s XXXXXXX flash:raw boot_a hybris-boot.img
Sending ‘boot_a’ (18520 KB) FAILED (remote: ‘unknown command’)
fastboot: error: Command failed
Flashing failed (1)

Can someone help?
Thank you,
Caluna

What would you get with:

fastboot getvar secure
fastboot getvar baseband

Also, try the flashing script when the phone is connected to a different USB port, preferably to a USB2 port or a USB hub.

Your link to the official instructions should be this: How to install Sailfish X on Xperia™ 10 II on Linux - Jolla

2 Likes

Thank you: I already checked. Switching to Win10 for flashing finally worked.

Some more elaborate and unofficial advice, in case the flashing fails due to USB issues (which are hard to pinpoint until a working way is found):
https://together.jolla.com/question/222126/guide-installing-sailfish-x-on-xperias/#222126-2-flashing-sailfish-os

2 Likes