Fingerprint record lost randomly

It happens daily on my Xperia 10 ii.

4 Likes

Have been running without any issues for quite some time, and I have been set up with three prints. But Friday last week I lost them twice within an hour. The usual “sailfish-fpd” x 2 restart brought them back.
Did forget to check the logs :frowning: Will try to remember next time.

1 Like

Happened again and I remembered to pull a log. Did one before the “sailfish-fpd” x2 restart and one after.
To who should I send them?

Still on Verla 4.2.0.21 and I start to get the impression that the vibration stops at the same time as the fingerprints starts to fail.

I sent them to @vige via a private message.

2 Likes

Happens to me also at random (10 II). However when I start “Add fingerprint” and go back, the fingerprints are there. So could be that something is disconnecting in between and the wizard is starting or reconnecting again?

Just saw @plemil “The usual “sailfish-fpd” x 2 restart” - will try this next time

This keeps happening regularly with 4.3.0, too. It starts to look more and more like an OOM situation… I disabled the zram, created a 1GB swap on my home partition (not good for the flash, I know) and raised swappiness from the default 25 to 50. Two days of intentionally heavy application usage all around, and the fingerprints still work. Apps don’t get killed (grayed out in the app switcher) anymore either.

5 Likes

I’ve noticed that this situation happens quite a lot after having put the phone on charge. I have no journal logs though. However, I skimmed through the journal log once and there were some warnings / red lines regarding cpu cores going sleep or something, I’m not really too familiar with journaling. As @direc85 pointed out, this might be some OOM situation. Might try to reproduce OOM situation to find out if the fingerprints are lost :thinking:. Are there any news about this issue? Somebody sent journal logs as far as I remember?

Running on Xperia 10 II with Sailfish 4.3.0 as well.

1 Like

In the Backup/Restore, where are fingerprints stored? thread, were given interesting informations.

EDIT:
It seems the fp generated files are located in:

/var/lib/sailfish-fpd/templates/

Do they they get altered?
If so, would it be an idea to restore them daily with a script and an app which can launch apps/scripts at boot or with the help of Sailcron?

My uptime ended; no missing fingerprints so far. Having separate swapfile and higher swappiness helped. Now I’m trying only swappiness of 35, let’s see if it helps…

Personally I really wouldn’t mess with the fingerprint data manually; restarting the service twice has done the trick for me every time…

I do mess manually with everything i can. :nerd_face: (and make some disasters sometimes).
It was just an idea to try finding an automatic solution.
Let’s try to copy those files somewhere, copy them back, reboot…

EDIT:
I rsync’ed the files forth and back, tried to reboot, still works.
But
-We don’t know if the problem comes from these files
-I don’t know how to automate a task as root (w/o installing some cronlike stuff)

I’m again tempted to leave WhatsApp behind; that bugger of a software starts its background services no matter what I select in Settings > Applications… In my effort to reduce memory pressure, I removed almost half of my Android applications as I simply didn’t need them anymore, or I can use the service through a web page instead. So far, with stock zram configuration, three days and no lost fingerprints…

Is there a OOM log to see what it actually snipes? @vige

2 Likes

Sorry, I have no idea

1 Like

systemctl stop sailfish-fpd && sleep 10 && systemctl start sailfish-fpd

seems that here I have to wait for a while between stopping and starting, but no need to restart twice

3 Likes

On my device, fingerprints dissapear within several hours after boot up (I don’t write ‘restart’ because there is no restart option in the interface, only turn off).

It seems that the bug will not be fixed, at least nothing has happened for many months.

So, what could be the best solution?

  • to turn off and then turn on the phone several times a day.
  • to forget about fingerprints and to unlock by security code.
  • not to lock the screen at all.

Have you tried systemctl stop sailfish-fpd && sleep 10 && systemctl start sailfish-fpd ?
Also, do they disappear from the settings fingerprint list or do they just don’t work any more?
Did you check if /var/lib/sailfish-fpd/templates/ directory still contains something?

You can activate this in Settings > developper settings

This depends on you own security/confort taste :–)

I can not say what is best for you. Of course you can always restart the phone but I do prefer first this as I have developer mode enabled.

Perhaps someone could write a small patch or app to trigger the sequence, but it needs root access, so it needs more programming.

To summarize if you do not have developer mode enabled, then best is restart. If you have developer mode enabled, you can try the solution in the terminal after login as root (devel-su)

Have been without issues for a long time but just now my prints where lost again.
Had to run the restart sailfish-fpd twice as usual. I had planed to try the start/stop with some sleep but forgot.

There surely is a way to launch a script at boot like through the links in /etc/rc5.d/ on a linux box. The only question is how?
Please sailmasters, a tip?

On my XA2+ in 4.2 I can download fingerprints but unlocking with fingerprint never worked, not once.