Finding Nemo - Xperia X

I’ve been a user of Sailfish since day 1 and have done all the updates along the way. Having screwed up my phone by altering files I needed to reflash it. Having only recently done a backup I thought that there would be no problem ssh’ing into to it to restore the backup from the sd card. Nope. SD Card is not writable. That’s funny it was before. Ah well, ssh into the phone and sort it from there. Permission Denied all the time. Rapidly getting p*ssed off by all this, I fired up the terminal (yes I had thought to enable developer mode) and did an 'ls of /home. Where’s Nemo? Instead I have default user. That is poor beyond belief. On any linux install I’ve ever done it asks for a user first so why doesn’t Sailfish?

But what annoys me as much as anything is that nowhere along the road have I been asked to create a user when doing updates. There seems no logic to this whatsoever. Still p*ssed off!

Off to play Angry Birds on my iPhone to calm down!

‘nemo’ was changed to ‘defaultuser’ last year in update 3.4 for all newly flashed devices.

Non-archaic desktop GNU/Linux distributions have actually not explicitly asked for a username for a decade (they base it on your ‘real name’), although you can still choose whatever you want. Presumably Jolla keeps the default user uniform to make it easier to troubleshoot problems, though I’m still not sure why that meant nemo had to go.


My point was that I wasn’t asked about any name. It’s smacks of poor design IMHO. I can see why corporate users might want a name other than nemo but surely nemo could still have been the default user for most/some. Ah well.

1 Like

That’s the key here - for all newly flashed devices. As of Sunday, it was all working fine and even with all the updates bringing it to 4.3 it still had only one account, nemo. Having flashed it and now having worked on it, I now have a user nemo, I’ve unmounted the sd card and mounted that under the nemo user so that I could restore a backup. But it’s restored it to the defaultuser profile and so all the SMS messages appear there and not nemo. None of the accounts have been recreated for either user and so this restore procedure appears to be seriously flawed. If I am to have to do all of this manually, it rather defeats the purpose of backups.

All in all, it’s left me feeling more than a little disappointed with Sailfish and I am sorely tempted to extract all the information from the backup, do my hardest to add it to my iPhone and sell the Xperia on to some other poor unsuspecting candidate who enjoys disappointment. Having had been with Sailfish since Jolla 1 days and been happy along the way, this has left a sour taste and I’m tempted to just give the two-fingered salute and move on. Such a shame when it shows promise but I fear those promises are never likely to be realised.

All I want is for the machine to go back to how it was a few days ago. That’s not much to ask is it?

1 Like

Someone posted here a workaround to restore backups.

1 Like

Sadly, while it may have helped others, it hasn’t helped me at all. I fear I’m going to have to do this manually which is more than a little irritating.

Thanks for info though.

When you set up the phone it should present you with the option of choosing username and hostname for the device.

Jolla doesn’t do it and its annoying.


I have flashed the phone again and set a Developer password and ticked the ssh option. Using ssh I logged into the phone and renamed all the defaultuser folders to nemo, of which there are 4. I then edited the /etc/passwd file to nemo. Rebooted and now it won’t get past the security code screen. If I enter the wrong code it tells me. So how can I get past this screen - preferably without flashing the damn thing again?

Oops, what did you do? :confounded:
At least /etc/group would have been worth to look into / edit.

And maybe more? There were also some hard-coded paths in some scripts of earlier versions.

It may work like this, but … is it worth?
WiFi is not working, right? So you would need to ssh in via USB.
It depends on your patience, self-masochism how far you would like to go!

Why not just a simple symlink nemo to defaultuser?


It’s not a good idea to edit /etc/passwd manually. I would strongly recommend to use dedicated tools such as usermod. Anyways I wouldn’t dare to rename the default user.

I renamed 4 folders
/home/defaultuser and finally I edited /etc/passwd to change defaultuser to nemo and then rebooted.

That’s when it all went belly up.

Is it worth it? Well that depends on how you personally feel about having a device run to your own requirements. I don’t care that Jolla want everybody’s phone to be encrypted and have a defaultuser. I don’t.

Wifi was working so I could easily ssh into it.

As for patience, I’m fresh out of that.

As for self-masochism, I say “Let sadists have a fair crack of the whip” (In case your English is not your first language, that’s meant to be humour :slight_smile:

Why not a symlink? Well at one point I had created another user called nemo but that had restricted rights and so didn’t have access to things like Store.

I’ve now flashed the thing yet again and am having another try at (a) removing encryption and (b) will be changing the user yet again but this time I’ve removed the PIN code first.

I’ve now swapped the SIM into my iPhone and so I have a usable phone again (I don’t normally use the iPhone as a phone, only for banking apps and the like).

I’ve been to the kitchen and now having had a fresh brew of tea, I have a replenished supply of patience so with renewed vigour I’m attacking the thing again. I’ll report back!


It’s a phone! Nobody is going to die if I screw it up. So I’m quite prepared to rename the default user. In fact I’m quite determined to do so.

As for usermod, I tried that but it still had hold a proc so I forgot that idea and then got sidetracked into doing it another way with poor results. But as you will see from my reply to @peterleinchen I’m having another crack at it.


usermod would take care of handling etc/ passwd and group
but renaming folders would be necessary either way

I like your attitude and hope you succeed!
Good speed

Or grab older 3.2.1 version (3.3.0 introduced encryption and 3.4.0 the ‘defaultuser’)


Where from?

So far I’ve flashed the phone and prior to rebooting, fired it up in recovery mode and removed a file as per this instruction
-# mount /dev/mapper/sailfish-root /mnt
-# rm /mnt/var/lib/sailfish-device-encryption/encrypt-home
That stopped the encryption and allowed me to bypass the fingerprint stuff at the beginning.

If I ssh into it and try the usermod command it tells me that it’s using a proc. I’m wary of killing that task as I don’t know what it is. But having removed the PIN lock and disabled encryption I’m prepared to have a go at simply renaming the files and the user as I did before, and if I break it, I get to keep all the pieces. Unless… you can point me in the direction of 3.2.1 and I can successfully downgrade and then upgrade repeatedly to get back to where I was last weekend!

I appreciate your help. Many thanks.

If you look around a bit before first boot, like with disabling encryption, it looks entirely possible to change the name of the default user…

This question goes to @Jolla !
But do not expect an answer. It was asked but this (management?) decision was never really explained.

With ‘grab’ I was a bit misleading you, sorry.
I should have written explicitly: ask nicely around and some fellow might provide you with it. But you need to name the exact model (F5121 or F5122).

Do you have some more insights? Or tips/tricks?
I am afraid just editing passwd and groups and renaming some folders will not be enough.

Encryption would be okay to me but ‘defaultuser’ is not (okay, not something serious stopping to use SFOS but).

I’m somewhat reluctant, because of the superficial nature of the problem and high chance of breaking things.
But put it this way; in the disassembled image (i.e. as the disk will look pre-first-boot) there is a grand total of 4 occurrences of defaultuser, two of which are groupadd and useradd. One is possibly a false positive.

Missing the “not”? In that case i agree, but that seems to only need to be a thing after actually having booted.

1 Like

Yup, ‘not’ was not there :slight_smile:

And thanks, that sounds promising! @toner_cloud?

Indeed. @attah Thanks for that. I’ll take a look at those suggestions.

It’s an F5121 model.