Failed to start Alien Dalvik (Android App Support not working)

Sony Xperia XA2, Rokua 3.3.0.16

I guess I have the same problem as the people in the following topics:
https://together.jolla.com/question/226357/android-application-support-doesnt-work-update-aliendalvik-control-if-installed/

I restart the phone, I wait for a minute and then I go to Settings > Android App Support. The Start and Stop buttons are both grey. When I try to start an Android app “Starting Android App Support to launch ….” is displayed in a banner at the top of the screen. But after this the app tries to start for another 15 seconds (spinning circle), than the app window disappears, and after this nothing happens.

I restarted my phone after every change I made.
I removed my Jolla account from the phone, added it back.
Removed Android App Support from the phone multiple times, reinstalled it.
But none of this helped.
Alien Dalvik Control is not installed on the phone.

When I run systemctl status aliendalvik in Terminal I get the following output:

aliendalvik.service - Alien Dalvik
Loaded : loaded (/lib/systemd/system/aliendalvik.service; enabled; vendor preset: enabled)
Drop-In: /usr/lib/systemd/system/aliendalvik.service.d
          01-prevent-start.conf
Active: failed (Result: start-limit) since *date* *time* 3h 30 min ago
Process: 11603 ExecStopPost=/usr/bin/stop-aliendalvik.sh (code=exited, status=0/SUCCESS)
Process: 10819 ExecStart=/usr/bin/start-aliendalvik.sh (code=exited, status=1/FAILURE)
Process: 10814 ExecStartPre=/usr/bin/start-aliendalvik.preinit.sh (code=exited, status=203/EXEC)
Main PID: 10819 (code=exited, status=1/FAILURE)

But no idea what it exactly means or what to do now.

I have the same problem, started a couple of days ago(. Sony Xperia XA2, Rokua 3.3.0.16.

Resetting to factory state solve the problem.

Same problem since yesterday.

A less destructive solution would be nice though :wink:

After I started this topic I continued searching for a solution, but the only offered solutions I could find were a factory reset or re-install. For me this would have been the second time in 15 months I needed to preform a full reset to get Sailfish working again, and it got me thinking.

The reason I was running Sailfish was because I wanted a Google-less phone as a daily-driver. But with Sailfish still having some stability problems (obviously), and my feeling that Jolla started listening to their investors instead of their users / community, got me searching for alternatives.

My phone is running LineageOS 17.1 now (without MicroG or GApps).
LineageOS is free and with 17.1 you will be running Android 10 natively.

I understand this is not a solution for everybody, but I’m running Lineage for over two weeks now and I don’t regret a second of it.

So yeah.

So Long, and Thanks for All the Fish.

1 Like