Factory reset Jolla Phone 1 without lock code

I recently bought a used Jolla Phone 1 which was factory reset, after turning it on and updating a little I found out that there is a lock code set and I cannot change/reset it. Is there any way to reflash it or anything so that I can use it fully?

You need the password or ask Jolla. I didn’t found an alternative.

That’s really stupid. Or to be more specific, the stupid thing is the lock code surviving a factory reset.

A begining of an answer here ? I think that you will need a pc (better with gnu/linux) and an usb cable.
Read also this guideline : https://jolla.zendesk.com/hc/en-us/articles/204709607

And i find also this answer : I want to reset my Jolla, but forgot my Security code [closed] - together.jolla.com

Recovery mode was the first thing I tried, it needs the security code, sadly as I stated in the first post, I never had the code so the last link is no help to me - I cannot remember something I never knew. Sending it to Finland doesn’t sound like something I want to do.

I once wrote this for a first batch item, dunno if it would work with the version you have (please scroll down to read the comments): How to: Bricked Jolla Phone Revival | C ä n n e ' s   N o t e b o o k

On Which Softwareversion are you ?
I think 1…
So i got a workaround when you not over… i did this few days ago…

I’m on 3.x sadly, I started updating before I noticed that there was a security code still set.

Arrghhh i noticed that on you can give a new code. and then reset to no code.
and then you get the chance to to factory reset via terminal / recovery mode.
Otherwise you have developer mode enabled ?
or untrusted software packages ?

Nope, neither of those. I basically got to updating it as soon as I turned it on, thinking I’d enable all the fun stuff later. Guess I was wrong.

Otherwise have you tried also factory reset via recovery mode ?

Yep, it says it needs the unlock code as well. After failing to input it multiple times it locked me out of recovery mode for 24 hours.

Very Sad man … evtl. there is a chance i found month ago a thread in the old forum…

Do tell, I honestly don’t want to send it to Finland to have it reflashed.

It very much looks like it should be possible to reflash if only you have the relevant files.
And turns out those are easy enough to build/package for yourself:

According to this, you can enter fastboot (from device off) by plugging in a usb cable and holding vol-.

That pmOS article even has a link to TMO with some other firmware files… (which i have not checked).

That looks promising! I’ll take a look at it during the week.

There are / were the images created with Coderus’ tool: Sailfish OS flashing files - maemo.org - Talk

With these you can reflash a Jolla 1, Jolla C and Jolla Tablet with a recent SailfishOS release, have a choice (on the Jolla 1) between using BTRFS and ext4, and a “factory reset” will reset to the newly flashed SFOS release.

*works only if you have already unlocked bootloader in recovery options

To flash the device you must unlock the bootloader first.
this is possible via reocvery mode.
i mean you need also the security code.
Only thing is to flash it via Deep Flash Mode (Qualcomm 9008 Mode)
I dont know if it is possible via deep flash cable.

“The best way to figure out the truth is to be wrong on the Internet”. :slight_smile: