English keyboards gets activated sometimes in browser without a reason

REPRODUCIBILITY (% or how often): maybe one in ten times or sometimes it can take long time without the bug
BUILD ID = OS VERSION (Settings > About product): 4.1.0.24
HARDWARE (XA2, X10, X10 II, …): XA2
UI LANGUAGE: Swedish
REGRESSION: (compared to previous public release: Yes, No, ?): yes

DESCRIPTION:

English keyboard gets suddenly activated sometimes when keyboard opens. I have witnessed atleast Jolla Browser do it. Maybe it has happened in other apps too but I’m not sure.
Then I need to go to settings to deactivate it again.

PRECONDITIONS:

I have WhatsApp, Signal and Fernschreiber running in background, otherwise clean boot. No patches installed whatsoever.

STEPS TO REPRODUCE:

  1. Open Jolla Browser
  2. Fiddle with internet address bar and write some addresses
  3. Sometimes it happens that keyboard will give you a capital letter in start of the address bar, then also English keyboard activates

EXPECTED RESULT:

One can write with the same keyboard as was chosen

ACTUAL RESULT:

English keyboard pops up and some the scandinavian keys vanish

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Do you have both Swedish and English keyboards enable? I think a screenshot of Settings -> Text input could be helpful. Showing which keyboards do you use and which one is set as default could give some more information.


Looking at file:///usr/lib/maliit/plugins/jolla-keyboard, en.qml is set as default layout (line 501 and 257). I think, value en.qml will load the file file:///usr/share/maliit/plugins/com/jolla/layouts/en.qml.

If you want to live dangerously, then changing value to sv.qml (not sure if sv is for swedish) could perhaps change things. Or not.

Thank you for your answer.
The active keyboards that I have, are:
Finnish, Swedish and the Emoji.

English is a keyboard that becomes activated sometimes without me activating it. And I don’t want it. When it for some reason becomes active then it doesn’t deactivate other keyboards - then I’m having 4 keyboards already - till I go and deactivate the English keyboard.

This problem is minor one, English keyboard doesn’t activate itselt often, actually very rarely. And I haven’t found yet any 100% sure trigger what makes it. I’ll watch it now closely and report here when I can a pattern in the behaviour.

I’m not so very savvy with programming, so I’ll skip the dangerously living with my phone :slight_smile:
Thanks anyway!

Now I opened the browser after clean boot (still in 4.1.0.24), and the keyboard it started with was English. Bugger off you stupid English.