Energy management very buggy

REPRODUCIBILITY (% or how often): Nearly all the time since the last update
BUILD ID = OS VERSION (Settings > About product): 4.3
HARDWARE (XA2, X10, X10 II, …): X10 Plus
REGRESSION: (compared to previous public release: Yes, No, ?):


Connecting the power supply does not charge the battery of the smartphone. This happens with various cables and various adapters. There is even a battery drain, and the following message message : “Puisance de charge insuffisante” (insufficient charging power). When the smartphone has not any more power, it reboots (because I have also the bug that make impossible to shut down completely the phone…), just after the PIN code, it reboots… Sometimes, it is possible to charge the phone when I twist in a particular way the USB cable. And some other times, it is charging normally with the USB cable in a usual state.


The phone has its battery partially or fully discharged.


  1. The smartphone is partially or completely discharged.
  2. A USB cable is connected with the power supply.
  3. The battery does not charge, and quite often it discharges.


The battery should be charged.


As described above.


The icon is always showing that the power supply is connected, but it seems that the system cannot correctly “accept” the energy. Quite often, when I away from home, I charge the phone with an external battery. This one shuts down automatically when it detects that no energy is needed, usually when no device is connected. And several times, when I connect my phone with this battery, it switches on as usual because it detects the phone (and the latter detects the power supply), but after two minutes, it shuts down because nearly no power is attracted by the phone.

Sounds very similar to this?

Yes, it seems that it is the same problem.

My Xperia 10 ii has done this a handful of times. unplugging/plugging all ends of the cable helped…?, strange workaround - then sometimes my PC complains that it doesn’t recognise the device attached, then it does. Weird. Not really a problem but clearly something gets confused once in a blue moon.

Have you tried with a different cable? This sounds like it might be a hardware problem.

I have 2, both are new cables, one bought separately the other cam with the device - I should add that I am running my USB-C cable with a 3 meter extension - I think powering that length of cable is an issue depending on what my USB ports of my laptop are doing.

Largely, it all works so I’m not in a rush to buy any more cables or create bug reports here. It did happen very randomly with my Jolla One, which is also being run through nearly 5 meters of USB cable - I think cable length is probably a dominating factor, at least in my set up.

Plz look again for dust in the port of your phone…

The port of the phone is clean, and the length of the cables I use is less than 1 metre. And as I wrote in the first post, the problem appeared with the last update. With SailfishOS X 4.2, I didn’t have this problem…

I don’t have a quick charge on my XA2.
I use Slowly charger 5v 2A, because QCharger not works properly

Here are some news about my Xperia 10 plus. I have changed the battery with a new one, and then I did the update to The results are… nearly no changes! The battery needs hours to be a little bit charged, only when the flight mode is activated. With the wifi on (only this one, and the other connections are off), there is no enough power to charge the battery. The USB port is perfectly clean, without dust or anything else. I will do a last try with the change of the USB connector, but I really think that it is definitely a software problem with this model. The some OS release works perfectly with my Xperia X, so it would be nice if Jolla really works on the bugs of Sailfish X…

1 Like

I have also noticed a strange behaviour. When I plug a USB cable with a charger, Sailfish OS detects that it is charging before I plug the charger on the power socket. But when the charger is plugged, there is no real electrical charge of the battery. So, is it a hardware problem, or a software bug ? I have tried different chargers, which work perfectly with other hardwares, and I have nearly the same result with this phone…

I have a smilar phenomenon:

Normal chargers and any USB cables do not deliver enough power (only about 100mA).

When the display is on the device pulls between 200 and 600 mA, if plugged that minus the 100mA.

BUT if I use a double-USB-C cable and plug the other end into a USB-PD enabled source (PC, docking station or charger with USB-C port), the phone does charge with 1100-1600 mA.

Also, PCs do not detect the plugged device properly (USB enumeration fails).

I blame it on a partially broken USB socket in the phone but do not know for sure. Port has been cleaned several times using several different methods.

Here is the end of this adventure. I have received today the new USB socket, and with it, I can charge normally the battery. So the issue was definitely a hardware one. Sorry if I thought it was a problem of the OS. I hope this topic will help the people who had the same problem.