Email attachment download slower than snailmail




gmail account, maybe a second work-related account on gmail.


  • Get a free GMail inbox
  • Get a mail with an attachment
  • Try to download the attachment in the mail program


The attachment starts downloading straight away


The attachment does not download straight away, but at some point later.


Mail sync is also really slow.
While aync is in progress, its impossible to display mail previews (the mail page stays blank)

Can’t reproduce, 120mb attachment test is still pending ‘uploading attachments’, but the 2.9mb tar.gz of midnight commander with .jpg attached passed and download completed in couple of seconds, archive still intact. Is the attachment huge?

No GMail here but two commetcial, one university and one self hosted email account. No problems. Maybe this is a GMail problem?
Attachments are limited in size at GMail, I understand.

I used to have this problem, but don’t any more. IIRC, the change for the better was unrelated to any updates, or anything i did.

100KB at most.
20 chars

Grrr i bet its some race condition

1 Like

Does download work on PC, maybe it’s a ‘virus’ (like mc source code tar/gzed is detected by GOOGOL)?
Edit: your irritation is probably GOOGOL saving you from malicious open source software, you should be happy

1 Like

Nope no virus, happens every time with any attachment.
And on PC all ok. Come to think of it, i have also a calendar sync on a work gmail account. Could that influence (timeouts?)

I’ve enabled that recently so doubt it, does wifi vs mobile make a diference?

1 Like

Hmm good point. Ill check.
Edit: same same.
but in general, synch also takes a really long time
whats the journalctl to trace mail client activity ?

1 Like

One more thing: Is it a googol account or generic mail?

Until recently, I was experiencing the slowness described above. Even the smallest files took ages to download:
It appeared as some kind of delay before the actual download started.
I’ve just checked again and it’s gone. The download starts immediately. I used two different accounts (Google and Microsoft) and both worked fine.
I would guess that this was fixed with, but I have no real proof that this is really the cause of it.
I bet more people have noticed the same thing. Can anyone cross-check?

1 Like

Exactly, however for me it has remained exactly the same.

See the bug description :slight_smile:

Ok so same as here, weird

For me it seemed to be in sync with the problem that accounts were often erroring out when sync’ing and it was solved when I removed and re-added the mail accounts…

1 Like

Well ill be damned, the sync is fixed by this. Ill test the attachments soon.
Edit: attachments load properly now!
incredible; maybe some timeout that crashes the lonely thread synchronizing all accounts??
Is the relative code available/open?

You probably got assigned another actual server behind the load balancer or whatever setup they have. :slight_smile:

Could it be caused by a very large, or very fragmented, SQLite database?

Deleting an account will delete all data in the mail db for the associated account. That could make sqlite perform better again.

Maybe there’s even an explicit VACUUMing somewhere in the account deletion/creation/first sync process.

To test this theory:

  1. Have an affected account
  2. kill/stop all processes and services accessing the database
  3. Make a backup of the database using either .dump or vacuum into sqlite commands (plain file copy is not recommended but should work also)
  4. Execute vacuum; on the original database
  5. Restart all services
  6. Test whether performance improved.

Hmm given authentication is still valid; I have a hard time finding reasons as to why the server would be the issue…except, if the server is really slow…but from google id expect this not to happen, as it would be a wider issue, i.e. Be fixed with urgency