[instruction] Storeman does not start on SFOS 3.4

Sailfish OS 3.4 includes a major upgrade of libsolv. Storeman is need to be compiled with a fresh SDK which is not released yet. Actual Storeman packages include a hack to force load a new libsolv but one need to manually reinstall Storeman after upgrading Sailfish OS to 3.4.


Same here. SFOS, Xperia 10 plus.

In the open-repos comments it was suggested to uninstall storeman and reinstall it. This worked for me:

ssh nemo@sailfish
pkcon remove harbour-storeman
pkcon install harbour-storeman

Thank you.
After updating I couldn’t open Storeman either. So no worries.

Thank you … this helped.

Huh, that’s weird, Storeman opens fine for me on Sailfish 3.4. This is on a Jolla 1 and Jolla Tablet, but I suppose it should be the same on any device.

Thanks. Btw. I needed to
pkcon refresh
before I could install it again.


Did the trick for me to!

I have a silly question. I had to do a complete reflash of my XA2 back upto 3.4 so I have nothing installed. I cannot install storeman from the download because of the libsolv.so.0 is missing. When I try to just install as you say I do not have this package available, do I have to add the repro to a list also ?

Try to install this version

This instruction is no longer relevant, since Storeman is now compiled separately for different versions of SFOS.


Hi, as you may have saw on your openrepos page I solved it. Sorry for the confusion, I just did not realise the unmarked version was for SF 3.4 where as 3.3 is for 3.3 and 3.2 is for 3.2. Really my mistake for lack of comprehension.

It’s really not entirely clear. I will upload explicitly named packages to OpenRepos in future.


I believe that I have the latest version of Storeman for 3.4 installed - and it also starts, but only after a strange delay of exactly 4 minutes! I.e. I click on app icon to start the program, the start up icon with the rotating circle shows for about 30 seconds and then disappears - and then after some time - 4 minutes after the click on the app icon - the Storeman interface pops up. What’s this all about?

Can you start it from the terminal with harbour-storeman and check the logs?

Good idea, why didn’t I think about this …but I get an error message: “Failed to obtain authentication”. So that was the reason for the delay, apparently. Rebooting seems to have solved the problem, for now. Thank you, Petr.