Can't share call recordings

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): from 3.4.0.24
HARDWARE (XA2, X10, X10 II, …): Jolla phone
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?): Probable? It used to work long time ago.

DESCRIPTION:

Can’t share phone recordings outside the phone via Email or Bluetooth. Email is sent with an empty attachment and bluetooth transfer fails.

PRECONDITIONS:

you have a call recording on the phone or make a new one and you have Bluetooth and/or Email account set up

STEPS TO REPRODUCE:

  1. go to settings->apps->phone->call recordings
  2. long touch a recording and choose “share”
  3. choose either Email or Bluetooth
  4. Share the file with the appropriate device or send the email

EXPECTED RESULT:

Bluetooth: WAV file is received by remote BT device, e.g. laptop
Email: email is received with a proper WAV attachment

ACTUAL RESULT:

Bluetooth: Message “Oops, uploading did not work” is displayed and file is not transferred
Email: email is sent but the attachment is empty (zero bytes)

ADDITIONAL INFORMATION:

Email source:

Return-Path: <sender-user@hidden.net>
Delivered-To: sender-user@in.hidden.net
Received: from in.hidden.net
	by node1.cloud.hidden.net with LMTP
	id bG6RMb0aR2HyOi0Aihkz/Q
	(envelope-from <sender-user@hidden.net>)
	for <hidden-user@in.hidden.net>; Sun, 19 Sep 2021 14:10:53 +0300
Received: from [192.168.0.107] (some.valid.domain [xx.xxx.xx.xxx])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	(No client certificate requested)
	by in.hidden.net (Postfix) with ESMTPSA id AD1AE175E2
	for <receiver-user@hidden.net>; Sun, 19 Sep 2021 14:10:53 +0300 (EEST)
X-Priority: 3
Subject: Test
To: receiver-user@hidden.net
From: sender-user@hidden.net
Content-Type: multipart/mixed;
 boundary="[)}<qmf:1355924282bbpbjPE3RFJgREzU2wljEQ==)}<]"
Date: Sun, 19 Sep 2021 11:10:51 +0000
Message-ID: <512a3d.qzohq5.1hge0yz-qmf@in.hidden.net>
MIME-Version: 1.0

This is a multipart message in Mime 1.0 format

--[)}<qmf:1355924282bbpbjPE3RFJgREzU2wljEQ==)}<]
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: base64

DQoNCi0tIA0K
--[)}<qmf:1355924282bbpbjPE3RFJgREzU2wljEQ==)}<]
Content-Type: audio/x-wav;
 name=+37052365154.+37052365154.20210916-150756107.0.wav
Content-Transfer-Encoding: base64
Content-Disposition: attachment; size=4744364;
 filename=+37052365154.+37052365154.20210916-150756107.0.wav


--[)}<qmf:1355924282bbpbjPE3RFJgREzU2wljEQ==)}<]--

Note: Possible cause is permission issues because the files are not accessible below /home/nemo/.local/share/system/privileged path when not using devel-su. The directory is accessible only to “privileged” user and group even if the files and directories below have ownership to nemo and group to privileged.

Wouldn’t that already be a legal problem? The function is illegal if the counterpart is not informed that a call is recorded. To now share a recorded phone call would be a next “illegal” step…

Oh, come on! That depends entirely on the the local legislation. For example here it is legal as long as one party consents, no need to inform the other. Also; solving social issues with technology isn’t a good idea… remember DRM anyone?

Sounds like it is potentially an access permission issue, but since it appeared before SailJail and wasn’t solved with the sharing rework in 4.2, it is probably more basic than jailing.

2 Likes

Hi, this is nothing to do with the legality of the feature which exist already. It used to work before, but not now.

Sorry, I can’t help with your problem, but I don’t really understand what’s going on here. The original Jolla Phone from what I remember never received the function to record calls, that was only added to Jolla C/Aqua Fish onwards. The Call Recorder app available on OpenRepos has always worked and still works, though, and is arguably more convenient to use. Perhaps you ‘hacked’ Jolla’s call recording functionality onto the Jolla 1 and the hack is no longer working?