Can't restart Silica (lipstick) from terminal in Kvarken 4.1 on Xperia 10 II

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.1.0.24 (Kvarken)
HARDWARE (XA2, Xperia 10…): Xperia 10 II-DualSIM fresh install
UI LANGUAGE: Spanish
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

Actually I can’t restart lipstick (Silica UI) from terminal in a Xperia 10 II

PRECONDITIONS:

Everything seems up & run correctly:
[defaultuser@Xperia10II-DualSIM ~]$ systemctl --user status lipstick.service
● lipstick.service - The lipstick UI
Loaded: loaded (/usr/lib/systemd/user/lipstick.service; disabled; vendor preset: enabled)
Drop-In: /usr/lib/systemd/user/lipstick.service.d
└─50-vendor.hwcomposer-2-3.conf
Active: active (running) since Sun 2021-06-20 13:37:13 CEST; 12min ago
Process: 5413 ExecStartPre=/usr/sbin/dummy_compositor (code=exited, status=0/SUCCESS)
Main PID: 5445 (lipstick)
CGroup: /user.slice/user-100000.slice/user@100000.service/lipstick.service
└─5445 /usr/bin/lipstick -plugin evdevtouch -plugin evdevkeyboard:keymap=/usr/share/qt5/keymaps/droid.qmap --systemd
[defaultuser@Xperia10II-DualSIM ~]$ systemctl restart /usr/lib/systemd/user/lipstick.service

STEPS TO REPRODUCE:

  1. Open terminal
  2. systemctl --user restart lipstick
  3. killall -3 lipstick
  4. systemctl --user stop lipstick
  5. systemctl --user start lipstick
  6. Any command that usually restart home screen, here fails

EXPECTED RESULT:

Lipstick should restart and working as it does after full phone restart

ACTUAL RESULT:

Every command I try, leads to an unresponsive home screen, but instead, it seems to broke the home screen.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

I get this behaviour when restarting it from sailfish-utilities too.

Yep, I created a post about this issue some days ago:

did you try first ? :

export WAYLAND_DISPLAY=../../display/wayland-0

then restart lipstick ( have too some trobles with starting GLESv2 appliacitons from terminal ( when try debug it with gdb server )

I have just done:

export WAYLAND_DISPLAY=../../display/wayland-0

and then:

systemctl --user restart lipstick

But there is no difference with only:

systemctl --user restart lipstick

After restarting, lipstick always freezes home screen.

Should I do something more?

The next OS update, 4.2.0, contains the fix for this.

3 Likes

Thank you very much!! As always, Jolla taking care of their users :smiley:

1 Like