Cant install Storeman

Xperia X factory reseted (after many problems)… this time cant install storeman, is the first time I have tried to install storeman since I did factory reset.

I download “harbour-storeman-0.2.2-1sfos3.3.armv7hl.rpm” directly from Openrepos site using native Sailfish browser, then select install and “ongelma asennuksessa” that means “problem with installation”, so any ideas?

What is your OS version?
If its older then 3.4 then use older Storeman.
If its 3.4 then:

  1. open terminal
  2. go to you /home/nemo/Downloads directory
  3. type: pkcon install-local harbour-storeman-0.2.2-1sfos3.3.armv7hl.rpm
  4. Show us output of your terminal.

Do a pkcon refresh from terminal as root.

@atlochowski

Im on latest 3.4.0.24

Terminal output:
Asennetaan tiedostoja (installing file)
Valmis (ready)
Vakava virhe (serius error): could not resolve: harbour-storeman-0.2.2-1sfos3.3.armv7hl.rpm

@jameson

Like Openrepos Storeman site says, I did “devel-su pkcon refrest” without any success.

I think you have the wrong rpm. That is for version 3.3. This is for the newer ones

https://openrepos.net/sites/default/files/packages/6416/harbour-storeman-0.2.2-1.armv7hl.rpm

1 Like

Ill try later but thanks for the tip

1 Like

@hetas

That version runs flawlessly, thak you.