Cannot update Signal

Months ago, I installed signal on XA2. It basically works fine, but now I don’t seem to be able to update it. I receive a notification telling me a new update is available, I click on it (which should take me to Signal and update it), but nothing happens.

Any other users experience the same problem? Any idea how to fix it?

You can download the apk here: Signal >> Signal Android APK

1 Like

That’s a great workaround, but it seems to me, being unable to update is a symptom of a bigger problem.
Where did you install signal from? If from an apk, consider using an app store that will help you. If you do use an app store, which one? Is it up to date? Do you have enough free space available to update?

I originally installed it from apk. Space should not be an issue. Any other ideas?

Does Signal have the permissions to install Apps on your device?
Settings > Apps > Signal > Open Android Settings > Install unknown Apps. Needs to be allowed.

1 Like

Yes, is allowed.

I also updated it several times ago in the past months, but for some reasons this does not work anymore. I can’t think of anything that has changed, apart from the last Saiflish OS Update.

I also have experienced occasional problems with automatic Signal updates. I then tend to refer to Signal’s website where the apk originally came from. Sometimes it works alright sometimes I have to download new versions from the website.

Threema does not have any problems with the built in update supply mechanism afaik.

I use an XA2 too and had this trouble occasionally myself.

In my case updating works in cases where the notification appears when I’m in an active Android app (in my case Firefox, NewPipe or AntennaPod). Not just on home screen, but in the app itself filling out the whole screen.

When I’m using a native app, the notification appears, too, but doesn’t take me to Signal and nothing happens.

What you could do is try to start up your phone and immediately open an Android app that you use (e.g. Signal itself). When the update notification comes, you should be able to update.
¯_(ツ)_/¯

Updating Signal using the notification never worked for me on my X10 II. However, the updated .apk is located in your users home folder at android_storage/Android/data/org.thoughtcrime.securesms/files/signal-update.apk
You can use the file browser, navigate to the signal-update.apk and open it to install the update. Any other means to open/install that .apk should work as well.

1 Like

May be i misunderstood something. But why you don’t use the Aurora Store to update Signal ?
It’s the way i used to update Signal since i used Signal (so since more two years ago). It is also the way i used to update all android apps that i installed by Aurora Store. And i do the same things for apps installed with Fdroid.

I use XA2 also, and it runs OS 4.0.1.48 . Signal version is now 5.26.11 and trying to update to 5.30.6 fails.

The app has the notification appear, and when clicked it takes to Signal download page, and downloading works too.
But after setting execute rights to the apk there seems to be no ‘install’ option in file browser when the apk is selected.

Has anyone come across this problem, and is there any solution found?

ps. I tried the start up phone and immediate Signal start, but no change.

1 Like

Try to load the current version at Signal:

See post from Oct. 28 2021: Cannot update Signal - #2 by emva

Why not update Sailfish to 4.3. It may be that Signal requires some files that you may not have as the 4.3 update contains fixes for the Android support layer. [Release notes] Suomenlinna 4.3.0

I had the same issue updating to the latest Signal version using Signal’s updater with SFOS 4.3.

Are you able to download another version from Signal and update in increments. Perhaps there is no update path for the version you are on now to the 5.30 version. I just went from 5.29 to 5.30 without issue. Do you have more helpful output on the terminal if you try installing the apk manually? Now it is shooting in the dark on a mosquito. :slightly_smiling_face:

The issue is (was) not that installing the apk manually is a problem, but that Signal’s internal update mechanism did not succeed.

I found from Forum an explanation to why File Manager does not give ‘install’ option.
The apk file is interpreted as a zip file, like below.

[root@XperiaXA2-DualSIM defaultuser]# xdg-mime query filetype /home/defaultuser/Downloads/Signal-Android-website-prod-universal-release-5.30.6.apk
application/zip
[root@XperiaXA2-DualSIM defaultuser]#

The bug is fixed in 4.1.0 , so I guess I need to update to that one first… dang… it was nerve-wracking the last time I did SFOS update, and I feel the same now already…

If you feel safer doing it on your own (but with other risks): sfos-upgrade | OpenRepos.net — Community Repository System

SFOS 4.1.0 is now installed, for some reason the Signal update from ‘Downloads’ did not seem to work, but update worked from the Signal GUI itself :slight_smile:

I’m happy :slight_smile: