Cannot download anything with Android apps

The owner is default user and the permissions are all set for the user. Storage is also set on Android apps.

I think @x-cell mentioned about media_rw will do the job. And I think after changing ownership and rights, I had to restart the phone.
I think stop / start Android App Support via settings should be enough. Instead of restart.
BTW: did you Disable Android App Support System Package Verification?

Like already mentioned, ‘media_rw’ is the default owner of anroid_storage not ‘defaultuser’. This also applies to the group. Set the correct owner, group and permissions.

1 Like

I just set the the owner , group and permissions. But the Android storage is still greyed out.
I give up for now, maybe i didn’t do the right thing.

Did you do it recursively, and have you rebooted since?
Otherwise it sounds you are due a reflash.

Or just delete Android support, deletethe android_storage directory and reinstall Android support. Could you post your current permissions and Ownership of androi_storage and its subdirectories?

Well, how that goes will depend how much of that comes from the relevant packages as opposed to exists always and whatnot. So if you hadn’t it sure sounds like it is time to bite the bullet.

android_storage is drwxrwx--- 12 media_rw media_rw
and all folders inside are drwxrwxr-x 2 media_rw media_rw
I don’t have much content, but it does work.

Or in other words @benhenderson

chown -R
chmod -R
are your friends.

Thx, i’m not a great expert but do understand. So i will first read the chapter how to change everything. But i think you all noticed that allready.

devel-su chown -R media_rw:media_rw /home/defaultuser/android_storage/*

devel-su chmod -R 770 /home/defaultuser/android_storage/*

I hope these commands are correct.

Tried it out, but there is no chance in the android storage. So i keep searching. Or otherwise try a reinstal again.

Could you post the output of

ls- -l /home/defaultuser/android_storage


There should be a space after ‘-l’

Thank you, now there is a complete outcome Just a typo so.

This is a better outcome from ls -l /home/defaultuser/android_storage

That does seem correct so your recursive ownership change seems to have worked
Edit: have you tried reinstalling android support?

Ok, i did reinstall the Android support but with no result.

I had similar problem but got it solved with:
devel-su chown -R media_rw:media_r
w android_storage/*

…at home directory.

Can the Sailfish browser save a file to the android_storage Download Folder?

It is important to have set “rwxrwxr-x” inside /home/defaultuser/ android_storage.

So: cd /home/defaultuser/android_storage
then: chmod -R ug=rwx,o=rx ./* *

/edit: AFAIK