Cannot download anything with Android apps

Its impossible to download anything on Xperia 10iii. It doesn’t download at all. Not only via Telegram, but also via browser, whatsapp and e-mail. No picture’s or documents download so far. When i start a download the screen turns black and there is no result. What can it be?

Strange its works perfect on the Xperia X

Try to run this command on terminal as root

chown -R media_rw:media_rw /home/defaultuser/android_storage/*

Thx,but the tric doesn’t work.

Does this problem only occur on Android-apps or also on native ones?

Can you describe exactly what happens when? If you navigate to a website with the (stock) browser and klick on a download-link, does it open the dialog to choose where to save the file? Or does the browser simply crash the moment you click a download link?

1 Like

When i download with the (stock)browser i can place the download where i want.
Its when using Telegram, Whatsapp, Diaspora or K9mail that the downloads or uploads doesn’t work.
When i want to download a picture with those the screen of the phone turns black. With upload they can’t see Gallery. So it is a Android app problem so far as i can see.

Okay, that sounds like an Android problem then.

Does the whole screen in the app turn black, or is a new app opened which displays a blank screen?
Also, just to be sure, have you allowed access to files for those apps in the Android-settings?

The screen turns black complete. Telegram try to open Gallery and then gallery opens with a complete black screen and sometimes there is no reaction at all, the app stays open and nothing happens… In whatsapp i see a gallery without pictures (empty) there is nothing there. Yes the apps have permission to open and use access.

I tried with my Xperia !0 III, and Telegram FOSS from FDROID:

  1. click on Image
  2. click on menu in upper right corner
  3. safe to gallery
  4. open gallery
  5. select folder “Android Storage” in gallery
  6. pictures are there

I tried sort of the same with fennec. Works.

Suggestion: Install something like “Simple Gallery” from simplemobiletool,com (FDROID). Grant rights to the app and try again.

Maybe this helps.

That doesn’t work. The android storage is not active. I can see it on the Gallery but its inactive.

What do you mean inactive? Like greyed out?
Have you done something to it, like symlinked it somewhere, tried to put it on sd-card or whatnot?

Correct it is greyed out. What i have done is very simple. Just installed Sailfish OS on the Xperia 10 iii and then there was this problem. Its impossible to make a change in storage if i choose for the sd-card there is the same problem it doesn´t work. Maybe i have to reinstall Sailfish OS.

After a reinstall the problem is still there. Its clearly a problem with the Android apps and specially Android Storage, it’s still greyed out.
I didn’t find a solution, with searching in my Xperia X, thats working perfectly.

Is there a way that i can start the Android storage threw the command line?

Do you have the ‘android_storage’ folder in your home directory?

Yes, its in my homedirectory.

Maybe permissions or owner/group are worth a look?

1 Like

Have not the same here. So there is something strange going on here. There is no the size of the storage is not there. It says its unknown.

Could you share some more information? Like who is the owner of the directory and which permisdions are set?

Maybe Android settings have to be changed. Settings / Apps / Open Android Settings. Allow Permmisions / Storage.

Thats allready done, but still not working.