Cannot delete very first (at the very bottom) video / image / screenshot in the Gallery App

REPRODUCIBILITY (% or how often): Always
BUILD ID = OS VERSION (Settings > About product): 4.4.0.58
HARDWARE (XA2, X10, X10 II, …): XA2 Plus
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?): ?

DESCRIPTION:

If you have a lot of images in the Gallery (at least more than can be displayed on the screen at once) it is not possible to delete the first first images that do show up in the very bottom (last) line (same problem applies to screeshots and videos) of the grid. It is possible to delete the images from the second last line - because the context menu with “Delete” shows up. Howevery if you select a image from the last line - it does not work, because the context menu with “Delete” does not show up on the screen - seems to be off screen. The image is highlighted, just the delete context menu is not visible - so there is no way to delete the image.

PRECONDITIONS:

You need more images, screenshots or videos in the gallery app so that they do not find on one screen - only works if you have to scroll down to the bottom.

STEPS TO REPRODUCE:

  1. Open the gallery app
  2. select images (assuming you have more images than fit on one screen).
  3. scroll to the last line of images
  4. long-tab on one of the images to delete it.
  5. the image gets highlighted - however you do not get the context menu to “Delete” the image.

EXPECTED RESULT:

Context menu to delete the image shows up.

ACTUAL RESULT:

Context menu to delete the image does not show up. Seems to be off screen.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

FWIW, I can not reproduce this on SFOS 4.2 (jolla-gallery-1.0.32-1.4.1.jolla.armv7hl), the delete menu shows up fine.
That would make it a regression.

Can you open the image and hit delete there?

Thanks for the bug report, bug created about this.