Can somone take over the development of Tasklist?

Hello,
a while ago, I asked the developer of harbour-tasklist in openrepos and store, if he could provide an aarch64 build version. He told me, he no longer develops Sailfish apps and some other developer should do it.
I know, there is a row of good task and shopping list apps for Sailfish OS, but TaskList fits best to my need.
Is some developer willing to create an aarch64 build of it? You can find the source on https://github.com/Armadill0/harbour-tasklist

Cheers,
kraemera

Since you aren’t asking for a feature request or a bug to get solved, I’ll try to describe here the required steps to perform a build for aarch64 on GitLab CI as wrote by CODeRUS (you could adapt these steps for GitHub too, but I like GitLab more :slight_smile: ).

    stages:
      - build

    aarch64:
      stage: build
      image: coderus/sailfishos-platform-sdk:3.4.0.24
      artifacts:
        paths:
          - "output/*"
      script:
        - mkdir output
        - mkdir ~/build
        - cp -r * ~/build
        - pushd ~/build
        - mb2 -t SailfishOS-3.4.0.24-aarch64 build
        - popd
        - cp -v ~/build/RPMS/* output
2 Likes

Thanks a lot for this advice. I am however a bit reluctant to start publishing applications on openrepos. I know, I ask a lot, but can maybe someone with more experience in Sailfish app development take this up?

I have adopted a few apps already, and I can at least try to provide an aarch64 build :slight_smile: No promises, though!

2 Likes

Thanks! Very much appreciated.

Forking an archived repo is not the way to go. Transferring the repo to a new owner would:

  1. preserve the history
  2. preserve the contributors
  3. Allow merges of requests
  4. keep the release history,
  5. etc.

Ask him if he’s willing to transfer (I accepted a transfer of tidings, which worked great).

Well, it wasn’t just a trivial rebuild, it seems… I had to create a Dropbox API application, and that has to use a different application name and Dropbox folder name, too. I should rename the application, or request the original API key and secret from the developer, and I bet I’m not getting those.

Even more interesting, I can’t get the translations working. The app has been coded so that the GUI language can be manually changed, which is the non-standard way to go. I’ll have to get back to this some other day.

Thanks anyway for looking into this.

Is there a new repo for TaskList? I am willing to spend some development time.

1 Like

No, please go ahead and fork the original repo .

If you get it working, please consider submitting to Chum.

Doesn’t this depend on a spec file ? the repo only contains yaml. I’ve tried pushing this through obs. No go. I think I’ll fork now. And there are sub-modules and, and, and.

Do you need the dropbox integration? Frankly, the way it’s done is not something I’m keen to work on. It’s ‘kinda cool’ in an odd way, but not really maintainable.

I never used the DropBox integration. For me it is not important.

Ok, thanks, I’ll have a look at a version without dropbox. system has other sync methods.

1 Like

Another stupid question, have you looked at something like the maintained To-do List from ichtyosaurus?

I’m assuming you have a bunch of data that’s stuck in the old app?

I looked at “To-do List” and also checked “Olive goes shopping”. Both are fine apps, but do not fit my needs. I basically need an easily accessible list of lists for different purposes, like shopping lists for different shops or for some tasks I do not want to forget.
It is less the amount of data, I needed to port. Atm. I help myself with an Android App from f-Droid called 1List, which is quite similar to Tasklist. However I actually would like to change back to a Sailfish app.

Sailfish SDK generatea the .spec file drom the .yaml file when you modify it. I think ot needs a template “empty” .spec, but you can create a new empty SFOS project and yoink it from there.

Removing the Dropbox integration would of course be a simplifying choice :slight_smile:

And yes, submitting it to Chum - although some ground work is needed - automates building new versions. I should find the time to learn it and throw my apps there, too…

Yo. it’s some effort to build to conform to chum AND harbour, but it’s worth it.

As far as syncing, I thought to look at the more global sync opportunities and maybe make a learning exercise out of it? The way drop-box is implemented is kind of a show stopper.