Bugs in Patchmanager ≥ 3.1.0

Please mark (“select”) the everything in the second post of this thread between the ***Start*** and ***End*** markers, hit the "Quote button (needs JavaScript enabled), delete the first line (which contains [quote="olf, post:2, topic:8552"]), also delete the very last line (which only contains [/quote]), then fill out the resulting form.

If you already have performed some technical analysis or can even provide a fix for the issue, please use the issue tracker and / or file a pull request at Github instead.

Only file bugs for the Patchmanager proper here, not bugs for patches:

1 Like


SailfishOS VERSION (Settings→About product→Build):
HARDWARE (Settings→About product→Manufacturer & Product name):
PATCHMANAGER VERSION (Settings→Patchmanager→[Top pulley] About):




(Please consider which other pieces of information may be relevant, e.g. denote if this is not always reproducible, if it is a regression, attach relevant data such as log files or the systemd journal, provide screenshots etc.)



Not sure the bug should be here (=all bugs mixed?) or in a new thread (= what I did here)

1 Like

I think you solved that almost perfectly by opening a new thread (“topic”) using above template, and leaving single line with a link to that new topic here.

The only improvement I can think of is to include the title of the new thread in the single line. Actually pasting only title linking to the new thread is sufficient, which is for this example:
[Bug] MMS doesn’t send pictures when Patchmanager is installed


After Openrepos certificate expired last week, then quickly restored, the patchmanager repository (web catalogue) is still not accessible.

1 Like

https://coderus.openrepos.net/ returns a 502 Bad Gateway

1 Like

Thank you @Objectifnul and @adekker for reporting, I retested (now, nine days later) and confirmed this, but then realised that @Objectifnul already moved this discussion (without mentioning it here) to:

This is fine, because this is not a bug in Patchmanager proper, rather a network misconfiguration.

On the other hand, maybe patchmanager could be updated if and when we have a new repository for patches (adjustable repo setup).

This should be fixed now (September 9th) see this Telegram message (Sorry, it seems the link works only if you are in the Telegram group Telegram: Join Group Chat, but it’s just Coderus announcing that the web app is up again.)

1 Like