Bug report:mobile internet on new devices

Since I cannot make claims about reproduceability, I put it here:

I got a new Xperia 10 III recently and installed Sailfish 4.4 on it.
For the first around 72 hours, the mobile data was stuck on 3g and it dis- and reconnected every two seconds or more. But as far as I remember, the connection worked.
In the meanwhile, I was trying to solve other problems and made many restarts. At some point, without knowing exactly why, I got a stable 4g connection. Just that I couldn’t get any data over it.
I then tried to remove the sim pin as mentionned in a thread including the second problem.

I haven’t found this combination of issues on a fresh phone in any thread, so I am making a new post in case it might help.

As it is highly likely that this is a problem with the configuration of your provider, could you share what telephone provider you are using?

Sure, I’m on Salt CH, which is also mentionned in thread I used for the second part.

Known and long-standing bug, see here:

These threads show only the second issue isolated. They completely miss the first one and their connection.
I am not searching for a solution, in case this didn’t get clear, I am just making a report.