Bluetooth doesn't get disabled if you press the disable button

REPRODUCIBILITY: 100% of tests
OS VERSION: 4.4.0.72
HARDWARE: Sony Xperia 10 III
UI LANGUAGE: German
REGRESSION: I don’t know, I have only been using SailfishOS since May

DESCRIPTION:

When you use Bluetooth and then disable it, it actually doesn’t get disabled and your phone can still be found by other devices (Although in the tests I performed, it seems that at least you can’t connect to the phone with Bluetooth “disabled”)

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Activate Bluetooth, use a Bluetooth device
  2. Disable Bluetooth either via the quick actions or through the settings app
  3. Use another device (e. g. laptop, another phone, …) and search for Bluetooth devices

EXPECTED RESULT:

The other device (e. g. laptop, another phone, …) doesn’t list your phone as a device it found via Bluetooth (so therefore Bluetooth on your phone is disabled)

ACTUAL RESULT:

The other device (e. g. laptop, another phone, …) will list your phone as a Bluetooth device that is available for a connection. (so this suggests that Bluetooth on your phone isn’t actually disabled)

MODIFICATIONS:

I have Chum installed, some SailfishOS apps and also some Android-Apps. But there is no app I would suspect to be the problem.

ADDITIONAL INFORMATION:

If anyone has any tips on how to document this issue better or to collect some kind of logs, please tell me.

1 Like

Thanks for your report.

This seems to be a duplicate of

which is marked as Tracked by Jolla.

1 Like

I’m not quite shure if this is a duplicate, in the bug report you linked, it states:

This is not the case with this report. The quick toggle AND the settings app both show Bluetooth as disabled when it actually is not. Bluetooth just does not get disabled at all, I need to reboot to get it disabled. Also, Bluetooth stays enabled even if I turn flight mode on.

Maybe I’m wrong, but for me this doesn’t sound like a duplicate. Or am I just understanding this wrong?

1 Like

This is an old story. Two years ago I found a workaround: With BT on (enabled), go to the settings, turn visibility off, then disable BT. Then it should be really invisible.
But with visibility on in settings, only turn BT generally off in top menu or even in settings, it stays visible despite it is ‘off’.
Not fixed by Jolla since how many years???
(I discussed with others who had the same problem abt 2 years ago…)

2 Likes

I am really concerned about this, because I am concerned that active Bluetooth in my pocket might be harmful for my health

Don’t worry, it’s harmless. BT has a transmitting power of abt. 100 Milliwatts. This does exactly nothing to your body. But this bug is a disaster for data security!

5 Likes

I must admit i did barely any testing of whether off means off in my report - i was only really concerned with having it on.