Backup of Android Apps - fails

when trying to create a backup of Threema or Signal App, I always get the error:
“Cannot write to this directory. Please choose another one.”
No matter which directory I choose, even SD-Card doesn’t work. When choosing the directory, SFOS asks for permissions, when granting it fails.

running SFOS
on Sony Xperia 10 II

Can anyone help here?

1 Like

How do you try to create these backups? From within those apps?
With another Android app? With something else?

I want to create the backup from within these apps. Both come with a build in backup functionality.

Okay thanks for clarifying.

And you’re trying ot save the backup files to which paths?

I have tried SD-Card first (my preferred path). Then I tried using paths on local FS - documents folder, downloads fold etc.
The error message is always the same. Even I’m asked to give permission when choosing the folder.

Try Downloads or Documents inside the Android storage and copy backups later to your SD.
Works for me on a weekly basis.

Thanks for that hint.
This workaround works.

But it’s really uncomfortable - Jolla should get this fixed.

I have the same issue. It was possible some versions ago, and for some Android apps it is still possible to save files (e.g. weirdly Opera can save websites, pictures, pdf’s from the net, but Vivaldi cannot), but others (e.g. threema, komoot, APKpure) simply crash or freeze when attempting such operation.
As I now have a Xperia 10iii and want to migrate the data to it, I’d like to have backups of some android apps using the builtin functionalities. However, some just don’t even have the ability to save anything - not even in the documents or download folders of the integrated android-storage. I have a XA2 Ultra, also on
Would update to as a first option to see if this improves the situation. If this doesn’t change anything, can anyone help?

Update: Version doesn’t improve the situation. My latest threema backup is from September 2021 - so I can go from there. But then all message-data since then is lost.
I really would like to have the ability to create a new backup an my XA2.
I think I’ll create a service-request then…

Why don’t you backup to Android storage?

Didn’t I say so?
I used the Download or Documents folders located within the folder ‘android_storage’.
However, it doesn’t matter which target I choose: It doesn’t work. Thats the point of this request.

Support advised me to generate journal-logs after I made some attempt to save files, which I did already send to them.
Should I upload these here as well?