Aurora store stopped searching

I have this with two accounts on two different phones, a Sony Xperia 10 and 10 II.

I enter a search query in aurora store and the page stays blank except for the filter option.
Everything else works, but it’s rather annoying not being able to find the app you’re looking for.

I use the secure anonymous account.


I had this problem with the last aurora store version. The latest update fixed it

Confirm that Aurora Store search doesn’t work anymore also on Volla / / WayDroid with the settings that previously were working. There has something changed.

edit: the Aurora Store version from F-Droid is one year old, version 4.1.1. Browsing through the apps in app lists and download and install still works.

Which version?

I’m using 4.2.1 from the F-droid store.

For me the latest offered and suggested version is 4.1.1 from 23.2.2022, other listed versions are older. Where did you find version 4.2.1, @sluimers ?

edit: Now I tried to install from APKPure and got the version 4.1.1(41), result: same thing.

I updated to 4.2.1(43) and search stopped working. Reinstall does nothing, nor logging out or in multiple times.

Fdroid suggests 4.2.1 which is working for me on a 10 II

Same version, same phone, yet it’s not working for me.

I searched for element and it displayed results. Do other android apps have internet access?

can you show app details from the main screen? Thus install apps without searching?

It migh also be a problem caused by google…

Do other android apps have internet access?
can you show app details from the main screen?
Thus install apps without searching?

Yes (x3)

It’s a problem with the APP.
I have the same problem, and it was already submitted to the developer to be fixed:


This happened to me. I solved it by logging out and then in again.

Temporary Workaround:


Thanks for the trick.
It took me some time to find the right way into SFOS, as I’m not very used to using Android App Support.
Here are all steps for potential other Android App Support Beginners:

  • Open SFOS settings
  • Scroll down to Android App Support, open
  • Click 5x on Android Version number. This will open Android settings.
  • Into Android Settings, click on Apps and notifications
  • Click on Default apps
  • Click on Opening links
  • Click on Aurora Store
  • Click on Open supported links, verify that Allow selected

Install an android browser, e.g. Firefox (better suggestions?)

  • Open the browser and go to the page of your choice where Play store (and probably Apple store) are present.
  • Long click on the Plat store icon, until the contextual menu arrives and select "Open link in external app"
    This will open Aurora and you will be able to install your app.

However, correct me please if I’m wrong, the apps that will be installed this way are less “depolluted” from undesired functions than the ones in F-droid or Aurora. Isn’t it?


just to add to the mentioned workarounds:

I didn’t have to bother with android settings. But I had to open Autora Store first, then keeping it open in background open Firefox. (Form here on like already said…) On the page that links to goople play store long press the link and choose “open in external app”, select Aurora store…

1 Like

I had some similar issue. I did a reset of the aurora app data (Sailfish Settings → Tab “Apps” → Aurora Store → Clean Cache or delete Data). Clean Cache or delete data brought it back to operation.

1 Like

Unfortunately none of the above methods work for me.

I set aurora to open, “Open supported links” is set to “Allow app to open supported links”.
I also tried to open Aurora via clicking on an app download link within Firefox.

When I enter a word in Aurora’s search and press enter, I get the message “Oops, This account is rate limited!” Actually I uses Anonymous login.

1 Like

I would say this is not a problem of Aurora, but the anonymous account. Too many people are using it.


For me the latest release/nightly buikd from the developer page works.
Now, the search promp invokes an android browser (im my case firefox), from which you can select the app and which would lead you back to the aurora app which then installs the selected app.

Are you using Aurora with a personal Google account?