App Contacts: no routing to a saved address of a contact with "Here we go"

REPRODUCIBILITY: 100% (always)
HARDWARE: Sony Xperia 10 III - xqbt52 - xqbt52 - - aarch64
UI LANGUAGE: Deutsch (user: de_DE, os: de_DE.utf8)


If I want to start in Contacts a routing to a saved contact, I got the message: currently not available.


  • needed maps are installed, WiFi is activated and has access
  • GPS is enabled
  • a contact is saved with: name, street, Zip-Code, country


  1. Here we go is installed in Jolla-Store: 1:2.0.11510
  2. Open contacts
  3. Choose certain address
  4. Tap on routing-Symbol


App “Here we go” starts and shows the route to the desired location.


Error Message: action currently not available (translated)


  • Patchmanager: no
  • OpenRepos: yes
  • Chum: yes
  • Other: no:


  • MicroG installed
  • If I use a typical Android-App, i.e., the routing starts automatically with Here we go, if I tap on the routing in this Android-App, so functionality seems to be given.

Device Owner User: defaultuser
Home Encryption: enabled

the initial version of this bug report was created using Bugger 0.9.8+git1

Same behaviour on my X10 II - Thank you for your bug report.

Here Wego from Jolla Store is completely outdated. It is an Android app anyway, so interaction with built-in apps is very limited.

Fun fact:.Simple Contacts from Fdroid with a contemporary He Wego from.Aurora works as expected.

But it worked better than the version of Aurorastore.
Perhaps Jolla could update Here in its store ;-).

This also happens with native PureMaps, Maybe its the same trigger/bug here.

The location in Contacts seems to be hard-coded to use Jolla Maps - it works gloriously in Jolla 1.

On newer devices copy + paste works, sharing doesn’t.

The current apps understand several formats - these are from Pure Maps for the best Kapsalon I’ve ever eaten:

Lekker 61, Isokatu 61, Oulu, Mainland Finland, Finland


Plus Code: 9GQ72F58+2R,25.46701

An easy to parse format would be

  • just dump the address at the end of the URL and replace spaces with + signs.

  • test the links on the SFOS Forum app by choosing Open externally

Thanks for the suggestion @Speedy-10 and for everyone for the useful discussion. At the moment I think this may be the expect behaviour (meaning that the functionality to route from Contacts to some arbitrary mapping service other than Jolla Maps isn’t supported).

Nevertheless, it does certainly seem like obviously useful functionality to support, so I’ve created an internal ticket about it and tagged it here as “tracked”.

Small addition:
If I start routing with “Here we go” and “mobile data enabled”, I got the message:
“connect to the internet and get regular traffic info? → ignore / settings”
(reproduceable: 100%)
I can’t enable that and get not current data to traffic problems … and got problems yesterday due to that missing information.
If I start the routing at home with Wi-Fi still enabled, I got the current traffic information for that moment.

So I hope, that the next update solves this “mobile data” problem with Here we go.

SFOS with J1 and Aquafish were working in the past.
I dont, t know why the link on Contact-adress is to all other map-apps broken.
This is a long time issue. Read in the old

Is there a solution to link the command “sailfish-maps” to OpenStreetMap with alias? Clicking to a saved adress should open the installed map-app?

After update to

→ solved in
A saved address is now routed with here we go
→ solved in