Android apps not installing on

While I want to thank all developers profusely for their great work on, I have to report the following behaviors on X10III, which in my opinions are caused by one and the same bug. They have already been mentioned in the comments of the Release Notes but I think they deserve a separate thread. In all stores listed below, app downloads succeed, but installation has problems, both on fresh installs or updates of already installed apps. The workaround of going to the relevant subdirectory of android_storage/Android/data/ (or similar) and manually opening base.apk usually works (as observed by @mkz )

  1. Aptoide fails silently
  2. F-Droid shows an error popup on many applications; others install normally.
  3. Aurora Store shows a black screen instead of the usual install confirmation popup. By blindly tapping several times on the black screen I did manage to update one app, but succeeded with no other (I have tens of them)
  4. Huawei AppGallery works, but the install confirmation popup appears at the center of a black screen, while on 4.5 it didn’t blacken the background. This makes me think that the problem with Aurora Store might be that the confirmation popup is actually there, but it is covered by the black screen (also already mentioned in the release notes comments)

I haven’t tested with other stores.

Some of the installed applications don’t work any more, but this is a separate topic.

Thank you for your attention


I don’t get even the black screen with aurora store. I suppose the install dialog is there, it’s just not visible.


The black screen appears if you tap the “install” button in the banner at the top of the screen that appears if the download is finished


Works fine for me with Aurora and f-droid on 4.6 0.11.

Need to click somewhere in the black screen to install/update after click the install button in the banner

1 Like

I’ve clicked everywhere on the black screen, nothing happens (XA2 Plus,

I litereally clicked every place in the black window - without success

I did that on two devices and for a couple of apps - maybe i missed something

Aurora does not install black windows appear after installation .But F droid run I could install any app

1 Like

Somebody in a Telegram group suggested that by setting the installation method as “AM Install” in Aurora Store, the downloaded APK’s are shared with an external App Manager. The App Manager which installs seamlessly from F-Droid can then be chosen and the installation succeeds. This isn’t straightforward, but in this way one can perform vital updates…


That indeed works! Indeed quite clumsy, but at least it works so we can breath easily while waiting for the fix.


Yes, this is an issue that came with I too did have no problems with Aurora Store on


I can’t say it worked ‘normally’, but after removing microG and co, I was at least able to install my banking app from Aurora store.

It was exactly as I suspected: the dialog is there, it’s just invisible. @rainemak was kind enough to send me a screenshot of the dialog, so I managed to install an app by guessing where the install button should be.


Guesstimating the install text position works and I was (eventually) able to update all my 10+ Android apps I have installed via Aurora Store. My tactic was repeatedly tapping from a bit too high to a bit too low, one of the taps should hit the button…

Edit: Can someone with test this and see if this is a regression from that version ir not? IIRC this worked for mw with but I’m not entirely sure…

You are right! I just found the place where I need to tap.

Mayby I should use a permanent marker for marking the place on the screen :wink:

In fact, it is pretty easy after the first try

So, the workaround is … when you want to install or update an Android app, and depending upon your phone, get a ruler and measure X mm from the side of the screen and Y mm from the top of the screen. Where the measurements intersect mark with a cross. At the appropriate time during the installation/update process tap on the cross to complete the installation :rofl:

1 Like

You could take measurements of that spot and share them here :grin:


For the moment, I fixed this whith this options [Release notes] Sauna - #47 by Juanro49


I can’t fix issues using that option before I try to turn on/off that option AppSupport crushes.