Alien dalvik + positioning = crash dalvik (impossible use navigation apps)

REPRODUCIBILITY: 100%
OS VERSION: 4...*
HARDWARE: Sony xperia 10 II, XA2
UI LANGUAGE: RU
REGRESSION: restart dalvik

DESCRIPTION:

when dalvik use gps, they crash, for fix it I restart dalvik via settings
apps for test: 2gis, yandex.navigator, telegram*
*example: open telegram => main menu => peoples near u (for start positioning)
try interact w/ tetegram or wait, after few minutes dalvik crash

PRECONDITIONS:

need dalvik and app for use positioning

STEPS TO REPRODUCE:

  1. buy and install alien dalvik
  2. install some Android app for using positioning (ex. telegram, yandex.navigator, 2gis)
  3. enable positioning
  4. start android app
  5. wait few mins
  6. try interact w/ dalvik (opened app)

EXPECTED RESULT:

I’m expect working apps

ACTUAL RESULT:

dalvik crashed and not restart automatically
using some navigation apps is impossible

MODIFICATIONS:

I use patchmanager w/ some patches, but I try test it on fully cleaned xperia 10II (after 1st flash from android to sailfish)

ADDITIONAL INFORMATION:

1 Like

It happens to me (XA2 plus, 4.4.0.68) sometimes, when GPS hasn’t got a fix yet with Waze.

what is this, fix via waze? I don’t know about waze

Waze is a navigation app (for iOS and Android).

Happens to me using HereWeGo

1 Like

I can confirm this behavior on my XA2. Initially i thought it’s a memory problem but after tweaking and thinking I came to this conclusion.

Can some of you try osmand and see if that crashes as well?
I am using it for hours without problems. Would be interesting to see if it depends on the app

Osmand crashed after aprox. 1 minute of usage. I just scrolled the local area.

Did you get a gps lock in this time? Does it also crash if you disable gps?

Did not get a lock. With deactivated GPS the nav apps seem not to freeze.

1 Like

yes, when positioning disabled or in search status, apps doen’t freezing, but when positioning getted, apps get freeze

2 Likes

Can you add this info to the first post, so its easier to find?

Thank you for trying, that is helpful I think!

i cant edit 1st post, sadly

@flypig can you do this?

yep, same sh##t on XA2+ every time when use any GPS application…
but on 10 III it works better, it crash some times, like 2 crashes from 10

1 Like

Same here on h4113 with Mapy.cz app. I think it started with Sailfish 4.3.