Advanced Camera 0.9.5 conflicts with fahrplan2

When trying
rpm -ihv harbour-advanced-camera-0.9.5-1.1.1.jolla.armv7hl.rpm
I get
Wird überprüft … ################################# [100%]
Vorbereiten … ################################# [100%]
Datei /usr/bin aus der Installation von harbour-advanced-camera-0.9.5-1.1.1.jolla.armv7hl kollidiert mit der Datei aus dem Paket harbour-fahrplan2-2.0.31-1.armv7hl

Does anybody know how to resolve this issue?
Best regards, Uwe.

Use the --force option (if Fahrplan2 breaks, reinstall it)
rpm --force -ihv …

From Upgrade to 4.1.0.24 problematic - #5 by olf

In general: One shall always use pkcon for managing packages on SailfishOS!
If its slightly slim feature set is not sufficient, one may resort to zypper (which has to be installed per pkcon, first).
Only use the very low-level package management tool (rpm on SailfishOS) for queries (i.e., rpm -q …) or if you absolutely have to, which is solely the case at the recovery console (which also shall only be used, when you absolutely have to).

BTW, this also applies to other Linux distributions, e.g. SUSE (use zypper, not rpm), RedHat / Fedora (use dnf / yum, not rpm), Debian (use apt / aptitude, not dpkg), Ubuntu (use pkcon / apt, not dpkg) etc.


Additionally and specifically here:

Do not use the option --force, if you do not know for sure / fully comprehend, what is going wrong (pkcon knows this option, too).
No matter with which command!


P.S.: I am becoming less and less surprised, that many SailfishOS users run into package management issues a some point, especially when upgrading SailfishOS, if they handle their duties as UNIX system administrators with so little diligence.

4 Likes

A safe and easy way:

  1. remove Fahrplan using Storeman
  2. install the downloaded Advanced Camera using a File Manager that has the Install option (harbour-file-browser)
  3. install Fahrplan using Storeman (or download the fixed version mentioned in the comments if you trust the guy and need something other than bahn.de)
  4. ask for help as needed (zypper ref as root solves many problems)

All my Sailfish phones had Advanced Camera 0.9.5 already installed, and Fahrplan installed without errors…

except for the Aqua Fish, which had Advanced Camera 0.7. Using Storeman I uninstalled it and installed Fahrplan and then using Chum-GUI installed Advanced Camera 0.9.5. No errors in this order, either.

Sorry for the delay in answering. Thank you all for your suggestions.
With Storeman I could install only Advanced Camera 0.9.0 but not 0.9.5.
So I used (despite of the warnings above) rpm --force. Fahrplan survived…
Anyway I also tried various orders of deleting and installing of those two apps.
Fahrplan works fine, but Advanced Camera only woks with the front camera. (See e.g. [Release notes] Verla 4.2.0 - #226 by enrish).

Thanks again, best regards, Uwe.

Can you please point me to the “fixd” version.

Because 0.9.5 is in Chum, not Openrepos. Storeman can install local (=already downloaded) rpm packages, though.


Switching between front and back cameras a couple of times works on the XA2 and 10 II.

Smurfy’s Fahrplan, Melvin’s comment from Sept. 14, the second “here”:
https://marvinborner.de/fahrplan.rpm

Switching between front and back camera did’nt work for me. Or does one need some other “magic formula”?
Best regards, Uwe.

Worked for me yesterday. Now X and XA2 are broken. Aqua Fish and 10 II are OK.

On the X the viewfinder comes on for a spilit-second, then the display goes black, the XA2 goes straight to black (maybe because it’s faster). The Aqua Fish starts OK, goes black for less than a second and comes on again and remains functional - this happens also when switching from front to back.


Starting from the console I got these error messages:

CameraBin error: “GStreamer encountered a general supporting library error.”

(harbour-advanced-camera:679): WARNING **: 06:58:02.135: viewfinderbin-capsfilter: transform_caps returned caps which are not a real subset of the filter caps