Cannot install Chum-Gui

Nononono. Don’t use bare rpm commands to install software.

There’s usually a good (technical) reason why zypper, pkcon or an UI application won’t install something. You need to fix that, not just force-installl a package.


yes, I used

rpm -ihv sailfishos-chum-gui-0.5.5-1.9.1.jolla.aarch64.rpm

Well, I downloaded the rpm from

Index of /obs/sailfishos:/chum/

How can I use zypper for that repo?
Best regards, Uwe.

btw: I used rpm often and with success…

I would also install from Storeman. But you could try “devel-su pkcon install-local /path/to/.rpm” or just try to install from filebrowser.

And maybe do “zypper ref && zypper update” before that as devel-su. This may fix some issues after update. I usually do that after Sailfih updates. Sometimes it updates things that haven’t been done in update progress. This is just my quess. Should not break nothing.

1 Like

Hi kaari,
Thank you very much. With your help I could install chum-gui.
Best regards, Uwe.

1 Like

Do use the SailfishOS:Chum GUI Installer, that is what I made it for.

Do never use rpm for installing or removing packages, solely for querying via rpm -q….

@uwelabs you seem to insist on wrecking havoc. Well, that is up to you, but please stop complaining publicly that things do not work for you: It is only you causing these mishaps.

TL;DR: Yes, you are “doing something wrong”, repeatedly, despite being told so.

1 Like

Dear Olf,

“despite being told so” sounds a bit unfriendly…
And I was not complaining but just asking…
But anyway…
I do not insist in using rpm. I’m using rpm in networks with linux and OES. So I’m kind of used to it. And so I ran into the problem with unresolved libs.
But I’m able to learn…

As I wrote I got it installed with pkcon as kaari described it.
Is that also not an “allowed” method?
Willingly I’ll study the links you wrote down in your post during the next days.

Best regards, Uwe.

Yes, because you are causing completely unnecessary support efforts for people doing this in their spare time: 5 people writing 6 messages because you did not read and use the documentation. Additionally you are creating the impression for less tech-savvy readers that something is not working correctly with the SailfishOS:Chum GUI app.

I like to write Free Software (FLOSS) and with it implicitly comes some support burden. But to answer the same things to the same people again and again makes me angry. I think that is understandable. BTW, it is not my task to “be nice” or to support anybody; still I do (support, not being nice), because many others do support me in their free time.

I do not insist in using rpm.

Well, …

I’m using rpm in networks with linux and OES.

…: Again, do not, stop it!

But I’m able to learn…

… really?

Willingly I’ll study the links you wrote down in your post during the next days.

You know the forum topic I linked to; you may not remember though. It contains replies to you doing the same before.

Baseline: Do search and read thoroughly before asking; if you do not it is you not being “nice”!


Dear Olf,

I’m really sorry if I upset you. It was not my intention.
And you’re right, I forgot I had looked into chum before.
The reason is that I don’t have that much time to delve into the technical details of SailfishOS very often. I came to the Jolla phones because I like the basic idea behind them and I wouldn’t like to go back to mainstream phones. So it happens that I usually only handle SailfishOS more closely when there is an update and of course I have forgotten a lot in the meantime.
I know that requests to a forum are sometimes duplicated. In my world of Microfocus Open Enterprise / Linux networks, which I know much better than SailfishOS, I also help many who have questions about these topics. Of course, it can happen that some questions come up more than once. So is life…
I can understand you, but I hope to calm your anger towards me.

Back to technology. If you like to answer:
I would like to understand, why rpm is not the tool of choice in SailfishOS?
Is this also true for pkcon?
What about zypper?
Is there a document that describes these things for SailfishOS?

Best regards, Uwe.

1 Like

Does this work for you in 4.5.x.y? It does nothing for me, am expecting to have the Chum GUI application installed.

Please open a proper bug report using the form at GitHub with the log file attached.

Before doing that you should read the “Important notes” section at GitHub or OpenRepos entirely.

P.S.: Please do report this bug with the necessary information; without a proper report, I cannot fix this, as I have no idea what is going wrong. Thanks!

Hi gabrielg,
I remember that I had also trouble with this. At least I got it installed with

pkcon install-local sailfishos-chum-gui-0.5.5-1.9.1.jolla.aarch64.rpm

with the rpm in the Download folder.
Best regards, Uwe.

Thanks, was really looking for confirmation. Will collect logs etc at some point.

This isn’t the installer though

Cannot confirm or deny:

  • I see many hundreds of downloads with zero bug reports at GitHub and zero comments at OpenRepos.
  • I have no device with SFOS 4.5.0 installed at hand.
  • I have read three “does not work” statements at FSO, none of the other two ever reported something properly when being asked for (one started this thread).
  • Edit: There is a single confirmation that it worked fine.

Hence I assume it works for almost everybody.

Will collect logs etc at some point.

The log is already there (i.e., “collected”), just report properly at GitHub and attach the log-file to your report.

Unless I’m missing something, the logs disappear in an hour or two thanks to excessive kernel messages. So, no, I have to collect them when I’m actually doing this.
I know it’s frustrating when folks say that something doesn’t work without evidence, but bear with us, a phone isn’t very friendly when it comes to terminal operations, or even writing here!

You are! Please do RTFM, this is what I wrote it for.

I know it’s frustrating when folks say that something doesn’t work without evidence, but bear with us, a phone isn’t very friendly when it comes to terminal operations, or even writing here!

SSH into your phone from your desktop computer; SailfishOS is just a Linux distribution.

1 Like

olf, ssh’ing into my phone and getting logs is what I mean by "collecting logs’.
I will ask you again to be patient and for the first time to be respectful - I hope that it is the last time, too.
I admittedly did not know that you wrote your own log file, which is fine once I get access to a computer.
Thank you for confirming that this works for somebody else in 4.5.x.y.
EDIT: sailfishos-chum-gui cannot be found. Like I suspected, we just need to wait for the packages to be available in the chum repo for the latest release, otherwise the repository is correctly configured in sfos.
Thanks again for the guidance.

But they are available there, see Show sailfishos:chum / sailfishos-chum-gui - SailfishOS Open Build Service.
Hence there is no need to wait for anything, which BTW never happens auto-magically; i.e., someone has to configure any new SailfishOS release for a specific repository at the SailfishOS-OBS.

Thus I keep on waiting for a proper bug report at GitHub.

I may be testing a SFOS version for which chum isn’t built just yet, so no need for a bug report.
Perhaps it would be nice if the chum installer failed if the repository is not available yet, or if it fails to find the GUI, but these are debatable issues, so I won’t open any bug.