[] Kuri doesn't start

Do you have a sample gpx file? I reworked the import and could take care of it if you can give me a minimal gpx file with a few track points

My impression is (was) that it is inherited issue from laufhelden. I am experiencing it for a long time.
I wasn’t debugging it in detail. I’ve learned quickly the old process (and the invoker) remained active.

You’re probably right. Perhaps it needs to be a long enough recording session for this to occur. So it could’ve been me attributing it to track upload (I only had strava) activity.

My usage pattern always was: start the application, start new activity, finish activity (say 40 mins walk), open recorded activity and do the upload, then close the app. In this scenario, it happens almost 100% of time.

I’ll try to change the pattern a bit to exclude uploading. I’ll close the app after the recording (without immediate uploading). It will probably take a week or so as I am not exercising so much. :wink: (no, I’m just not sure synthetic scenario (say, recording of a 5 second virtual walk) would be representative)

I’ve sent You a message via this board, but I have no idea how this works (ie. cant find a way to view send messages). Let me know if you got the message and the .gpx. :slight_smile:

Sorry for late respone. Iny my case Kuri starts normally each and every time and each and every time, when I click “start workout” I get info that “Page cannot be loaded”
Im using 32 bit version on XA2 Plus
What can I do?

Can you run the app in the terminal and post the output after Page cannot be loaded is shown?

It doesn’t start from terminal:

Im trying 32-bit version on XA2 Plus

I’m running out of ideas. Since other were able to run on 32 bits, it seems to be an affect not many observe.

Can you run other applications from the terminal? Did you try to reinstall kuri?

The bluetooth issue won’t be solved anytime soon. I wasted quite some time to create a proof of concept with kfbluezqt just to realize that the version shipped by sfos is terribly outdated. I’m just fed up with sfos development at this point. Just trying to get 0.5 out and then I need a break until the situation improves.

A workaround for the bluetooth issue is to install qtconnectivity-bluetooth from QtConnectivity Bluetooth | OpenRepos.net — Community Repository System. At least on the emulator it worked without problems.

There is now a v0.4.90 release on Kuri Testing | OpenRepos.net — Community Repository System. Except the missing local export to GPX this will eventually become v0.5. The export to GPX will be added soon. Please test. I refactored quite a lot but overall code quality should be better than before. Activity recording/loading is affected the most and the data is now stored in ‘.local/share/org.kuri/kuri’. This should make it possible to enable sandboxing in the future.

You can always go back to v0.4 and redo the migration of the activities when switching to v0.5.

Hey @elBoberido I installed your update but nothing has changed in my case.

I ran kuri from terminal beeing non-root, this is what I’ve got:

Are the Mapbox QML bindings installed? Maybe they need to be updated if they are installed.

They were not installed, nor the bindings, nor libraries. Sorry for beeing such a noob, but to my defense I previously installed kuri ignorig Mapbox QML and I think it worked fine. But Im not sure right now.

After installing bindings and libraries app work as intended. Thank you @elBoberido for pointing me in right direction!

No problem. Sometimes one can’t see the forest for the trees :slight_smile:

1 Like

I just started hitting this… Yesterday I recorded an exercise, and closed the app from UI as usual. Today I did another, and the app wouldn’t start. Running it from the command line worked however, and I tried these:

  • harbour-kuri
  • invoker --type=qt5 harbour-kuri
  • invoker --type=silica-qt5 harbour-kuri
  • sudo -E -u defaultuser -g privileged harbour-kuri

So it doesn’t seem to be a permission issue (and Kuri opts out from Sailjail).

Then I remembered this thread, and indeed, the harbour-kuri from yesterday was still running in the background. So, I killall'ed it and it starts again from the launcher. I’ll plan to do an exercise tomorrow too, I’ll start it from the command line (with the sudo command) and see what happens.


I have the same. Initially (see my previous post) I thought it was linked to uploading an exercise immediately after the recording was taken. But now it happens every time I use the application.
I haven’t had any time to do any kind of under the hood investigation.
It seems something(?; perhaps a resource busy) is preventing regular closing of the application. So, the new invocation then fails to start it

I think this behaviour is fixed with the latest development version. There is a v0.4.91 pre-release on Kuri Testing | OpenRepos.net — Community Repository System and if there are no big issue I will officially release v0.5.0 next week. You can try the pre-release and check if the issue is indeed solved.


Did anyone had the chance to use the v0.5 release and can confirm that the issue is solved?

I’m on v0.5 since the release date. No issues so far. I suppose the issue is fixed. Thanks a lot!

Previous version (0.4 sth) regularly hanged for me on the exit preventing successful start of a new session.


That last sentence is not entirely correct. I’ve noticed that there is an issue with a login token. I can successfully login to Strava (as before) and upload tracks immediately after logging in. But later (say a day or two later) the upload stops working. The login appears to be valid, but the upload just does not complete.
The only remedy is to log out of Strava and log back in. Then the same thing happens again after a few days.

For me just looking at My Strava activities refreshes the connection and then the upload works every time. I logged in when the Beta version came out.

I’ll try it next time the problem occurs.
I did exactly the same thing once, but I was not careful enough to check the effect afterwards. So I might have missed it. I’ll check next time when the problem occurs and see if the workaround works for me.