[] Kuri doesn't start

Hey. Recently I got an XA2 Ultra and installed newest sfos on it

I installed harbour-kuri for my runs but the app doesn’t start, why I try to run it from xterm it gaves:

[root@XperiaXA2Ultra-DualSIM Downloads]# harbour-kuri
harbour-kuri: error while loading shared libraries: libQt5Bluet
ooth.so.5: cannot open shared object file: No such file or directory

How can I fix that?

I have a XA2Plus with 4.5 and harbour-kuri starts normally. Which version? Mine is 0.4.5

Your version of the app uses a library that isn’t installed on the latest (2?) Sailfish os versions. It works fine with XA2, but it doesn’t start on XA2 Ultra after fresh sfos install

I have lastest sfos version. Freshly installed. Any idea how to get those missing files? Or how anyway solve it?

It seems to be a dependency issue; please ping the creator of the application about this.

On my XA2Plus, libQt5Bluetooth.so.5 exists because I upgraded form 4.4 and the file remains from that version.
On my X10 III freshly flashed with 4.5, I can’t install kuri,it complains it can’t find libQt5Bluetooth.so.5

1 Like

I think this may be liked to Deprecation notice: bluez, gnutls, qtconnectivity, qtsysteminfo, repomd-pattern-builder

So you mean


QtConnectivity has in the past been used as an interface for Bluez 4. However, with the bluez package being dropped it no longer makes sense to have the qt5-qtconnectivity-qtbluetooth package. App developers are again advised to switch to using the Bluez 5 DBus interface or kf5bluezqt.

Copy from the XA2.

Isn’t it possible to install missing packages anyway?

I know from the guy himself, that due to the time limitations he doesn’t have much for kuri

So we may not have kf5bluezqt compatible kuri package anytime soon

Sorry, we posted at the same time :slight_smile:

Ill try that today and report it in here

Yes, happened to me (and IIRC some others too)

press volume-up (first) keep it pressed and press power-button – after a few seconds
the device should reboot and most probably the phone boots up fine.

1 Like

I’ll check if there is a quick-fix for Kuri v0.4.5. If not I’ll try to speed up the release of v0.5.

The quick-fix might just disable Bluetooth for SFOS 4.5 to at least have some minimal working version.


Yes, worked for me too. Thanks!

I created an account for pre-release testing on openrepos and uploaded a version without Bluetooth support. Please check if this works Kuri Testing | OpenRepos.net — Community Repository System


Works for me! X10II.

1 Like

Need 32-bit version as im using xa2

Should now also be available

For me Kuri starts once and a second start wont work (circles around in waiting and then dissappears). But running harbour-kuri from terminal always works.

Btw. is there a way to import gpx from strava? (expotred from different device/OS) I’ve tried, but its empty.

I’m experiencing the same. I’ve found out the process stays in the background. This happens only after uploading of a track to Strava. If I just start the program, it closes normally.

killall harbour-kuri removes this old process and new process starts fine after that.

Yes, that is a problem with the latest release. Unfortunately I don’t know exactly why it happens. I was able to attach a debugger once when it hang in the background but the backtrace only showed something from something from the invoker. I was able to trigger the behaviour once starting directly from the terminal so this might not be the root cause. I also don’t think that it is related to strava since I don’t use it. It seems to be related to opening the details page. The good news is that I didn’t observe this behaviour on the latest development version. The bad news is that I have no idea if it is fixed or just happen more rarely.

If the problem persists after the next release, my next bet is the map. There are Timers cannot have negative values warnings when starting from the terminal and the detailed page is opened. This correlates quite well with my observation that it is triggered whit the details page.