[4.5.0.16] Hotspot stopped working on XperiaX after update

Some more thoughts: Here we use two XPeriaX, the one with OS 4.4 still working fine and the one i updated to 4.5 which lost part of its usefulness because of the defunct hotspot feature.
I could perfectly understand if 4.4 would be the last version usable on XPeriaX because development or testing ressources are completely engaged to support new phones. I just need to know.
So my questions are:

  • Does anybody know whether there will be a fix in a future version? If so: When?
  • Is there a way to revert to version 4.4? By brute force like dd to sd-card on the running device and dd from sd-card on the crippled device?
    Thanks in advance.
1 Like

It’s pretty bad bug; so most likely.
(That’s unless it is caused by some weird incompatibility leaving only some old installs broken, and not new ones)

Nobody (that can talk about it) ever knows this until everybody knows.

Well flashing from scratch always works. But you need said files to flash, and old versions are not officially available.

2 Likes

That’s unless it is caused by some weird incompatibility leaving only some old installs broken, and not new ones

Has anybody tested to flash XperiaX from scratch to 4.5? If yes I would like to hear the results if the flashing affects or not.

1 Like

I can confirm the problem exists on F5121 and I also tested it briefly on an older, several times updated F5122, where it also didn’t work.

I followed your suggestion and reflashed the F5122 with Sailfish_OS-Jolla-4.5.0.19-f5122-1.0.0.10.
Unfortunately, this didn’t solve the problem, I can set up internet sharing via WLAN in the GUI, but I never see the hotspot on other devices.

4 Likes

Unfortunately I have the same problem with my XperiaX and 4.5.0.19.
I can activate the hotspot but it is not visible to other devices.

2 Likes

Same issue. Hot spot is an important feature. Please correct the bug soon.

3 Likes

Suddenly, today the hotspot with the volla 22 and the latest SFOS works. I do not know, if it will work the next times I test it. And I don’t know what I have changed.

Yes, this is indeed a valid bug and is caused by wpa_supplicant upgrade from 2.09 to 2.10. Built manually the older version and installed that on f5121 (XperiaX) and tethering does seem to resume working as it should. I wonder if this is an issue with the older kernel the device has or some configuration option that would be needed for the wpa_supplicant.

So now we know what causes this and we’ll try to address the issue.

3 Likes

For all who are facing this issue on f5121 regarding tethering not working:

I created a downgraded version (to 2.9) of wpa_supplicant that can be installed from community OBS repo by:

  1. Developer mode is required and preferably ssh connection to the device (can be done on the device terminal app as well)
  2. SSH in / open terminal app and login as root (devel-su) and add the repository:
    ssu ar wpa_supplicant_downgrade https://repo.sailfishos.org/obs/home:/jlaakkonen:/wpa_supplicant_downgrade/armv7hl
  3. Update repositories and install the new vesion:
    pkcon refresh && pkcon install wpa_supplicant
  4. Restart wpa_supplicant:
    systemctl daemon-reload && systemctl restart wpa_supplicant
  5. Preferrably reboot the device - I noticed that first attempt to enable tethering while WLAN was connected after the service restart did not seem to work, but power ->off->on for WLAN made tethering enabled on the next attempt.

When the package is updated by us it will be overwritten by the new version. In the upgrade process all user added repositories are disabled so, therefore, this approach should be safe.

Please let us know how this works out for you. On my recently flashed testing f5121 tethering now seems to work fine.

EDIT: alternatively, you can download this after logging in to community OBS directly on your browser and install it via UI.

8 Likes

Thanks for those instructions. For me this has indeed fixed the issue. I did not test it before rebooting as I had to re-insert the SIM card first anyway. But after a reboot it just works.

3 Likes

I would also like to thank you for solving the problem.

3 Likes

I can also confirm it worked on my Xperia X. I applied the instructions while being on mobile data connection (wifi turned off), using the phone’s terminal, and it worked immediately, no reboot was needed. Thank you!

2 Likes

Should this also work on the dual SIM Version F5122?

Thanks @jlaakkonen, your package solved the problem. I tried to use the hotspot on my good old Xperia X during a trip abroad obviously for the first time after the upgrade. Luckily I

  1. had another phone and
  2. the solution was already available here.

P.S. Come to Tampere Linux User’s group meeting (when we finally manage to arrange the next one…) and I’ll invite you for a beer :beer:

2 Likes

Not 100% sure as I haven’t got f5122 at my disposal but the phones are otherwise identical, except the dual SIM support of course so in theory it should work.

1 Like

You are welcome. I have to remind that this is a mere temporary fix, we should find what is causing this regression on the newer wpa_supplicant on these devices to really fix the issue also in the future. But at least the devices that were suffering from the lack of tethering because of the upgrade can now get it back.

Thanks for the beerinvite :wink:

1 Like

Works again now . Thanks

2 Likes

Unfortunately does not work for me. The step “pkcon install wpa_supplicant” gives an error “The packages are already installed”.
Downloading from OBS is impossible. I seem to not be registered on OBS and sign up seems to be disabled.
SFOS version is 4.5.0.21

Which version is installed?
wpa_supplicant -v

During the update process to the version 4.5.0.21 I got a message, that I should remove wpa_supplicant before installation. I did not do that. The installation process proceeded normally.

After installation the hotspot did not work as expected. I made again all the steps 1-5 @jlaakkonen instructions. I noticed, that I could have skipped the repository addition in step 2, because I got a message that the repository has been already added.

Thanks again, the hotspot is working again.

2 Likes