[4.5.0.16] Hotspot stopped working on XperiaX after update

Hi, just for information. My Rephone with 4.5.019 connects to laptop with wlan hotspot and usb tethering but gets no internet connection. Firefox, system updates, e-mail does not work on laptop (SolusOS). But TOR-Browser works and lets me brows the internet. No idea why. Maybe this can help. Still thanks for your work.

Try Testing CLAT for IPv6-only mobile networks if your provider is IP6 only might help

Thank you! Hotspot works again.

1 Like

wpa_supplicant v2.10
(C) 2003-2022

ssu ar wpa_supplicant_downgrade https://repo.sailfishos.org/obs/home:/jlaakkonen:/wpa_supplicant_downgrade/armv7hl

This is ONE line command that you have to run in terminal to add repository from OBS.
There is no need to register or sign up to OBS.

This repo is shown by pkcon. Addition of the repo worked, just could not make pkcon install the version from this repo.

Had a different idea today: Followed the repo link, downloaded the .rpm manually and installed the then local file using zypper.

This method worked. After reboot wpa_supplicant reports 2.9 and the hotspot is visible.

Thanks for the support!

1 Like

Another way is to:
pkcon install --allow-downgrade wpa_supplicant

I did that before. This command (with the “allow-downgrade”) did not install the downgrade, just reported “already installed”.
I did not want to disable the main repo where the 2.10 version came from. I am not experienced with pkcon and did not want to change its config.
But i do have experience with zypper and it is a .rpm file. Should have thought of downloading the .rpm and installing with zypper earlier.

My conclusion is: To install the 2.9 version: Follow the repo link with a browser, download the .rpm, open a shell, switch to devel-su and install the .rpm with zypper.

This is still an issue with 4.6.0.11 (EA) on my Xperia X. Hotspot is not visible from other devices.

1 Like

It’s a pity. I was hoping, that this issue, which last for more than a year would be solved. Maybe the only solution is to use the work around which is described in this threads.

2 Likes

Could be. I was also hoping that the patch would have been incorporated in newer releases.

@jovirkku @jlaakkonen the forum marks this bug as “solved in post #30” - do you still track it internally?

1 Like

There is no patch. The problem was that the newer version of wpa_supplicant causes this, the solution was to downgrade. When we release 4.6.0 to general public we will build a new version with the new codebase of that downgraded wpa_supplicant.

We’re unsure what causes this. The upgrade of wpa_supplicant is rather large so finding the cause for this without breaking anything else is something we have no resources to put into. It is the unfortunate truth.