Hotspot not working in Xperia X II SalfilshOs

Good morning everyone,

I open this space for a problem that I can’t solve. I own a sony x II, with salfishOs When I use hotspot the line is seen by the Pc, but it does not allow me to surf. My phone provider uses IPv4 and I have tried setting both dual and IP.

I have tried these solutions but to no avail.

Does anyone have the same problem as me? How did you solve it?

Thank you for your help and time,



Which is your mobile phone provider?

Iliad (Italy), thank you for your time

What device is this exactly?

Read it as Xperia 10 II (roman numeral X for 10)

There was a Xperia X, which not a 10 at all.

Assuming the device you mean is Xperia 10 ii, I have the same device and same provider Iliad, and hotspot works ok for me on the latest update.

Good morning, thank you for your help.
The model is Xperia 10 II, I apologize for the inaccuracy.

kind defactofactotum,
but did your xperia work right away? I tried to do a re-install, but it didn’t work. Could it be a smartphone problem? Could this happen? If yes, what can I ask the repairer? with android it works. But Sailfish is Sailfih.

could there be commands to run from terminal?

no, I don’t think so. Seems more like a problem with the password authentication on your pc…mine worked straight away, I didn’t do anything special. If you’re really stuck you can try usb tethering to your pc…you have to install a small package first, search the forum for ‘usb tethering’

When I connect it to the PC , the PC reads the hotspot , prompts me for the password and recognizes it. But when I browse it duces me that I am not connected. I will try to follow the track you suggested. Then I will update the chat . thank you for the advice.

Same experience on the Xperia 5 port: hotspot gets enabled and is connectable, but connecting an Android device gives “Connected, no Internet”.

Pinging the Internet from the connected device works, but even a custom DNS (DoT/DoH/DNSCrypt) would not let it access webpages.