[][10II] Android App Spotify is not able to use SD Card

REPRODUCIBILITY: Yes, always (app removed and reinstalled, Cache deleted, Data deleted, phone restartet)
HARDWARE: Sony Xperia 10 II


After installation of SFOS “spotify” is no more able to store music on the SD Card. Within the App settings a SD-Card is shown with the following link “/data/misc/profiles/cur/0/com.spotify.music”.
However this link seems to point at some storage on the device, so the device storage is used to store music.
I already tried [][10II] Android App Audible is unusable saying SD Card required (solved), but that did not help.


I do have Spotify installed via “Aurora Store” and do have a premium account and was able to login normally.


  1. Open Spotify
  2. Tap on Settings Symbol on home screen
  3. Scroll down to “Speicher”/“Storage” and open
  4. “SD-Karte” shows the above mentioned link and there is another entry “Gerätespeicher”


There should be an entry “SD-Karte” showing the size of the SD Card and after selecting all music should be stored in the SD Card as before.


Music is stored on the device and device as a result is running out of memory.





Spotify on my XA2 is still using the SD card.
Can other Android apps see the SD card?
As a trick, try moving Spotify cache directory from internal memory to the matching path on the SD card: I remember years ago that doing so Spotify did find and use my SD card.

Other Android Apps (e.g. Filemanager Pro) can see the SD Card as always…

Weird. Try what I said, move the Spotify cache directory from internal memory to the SD card.

Could you please give a little bit more details on how to move the cache?

Copy the contents of the com.spotify.music directory you see in preferences into Android/data/com.spotify.music on the SD card.

Thank you a lot.
I have copied all “com.spotify.music” to the SD Card and chowned all to defaultuser.media_rw as all the data on the SD Card.
However, that did not help :-/

Sorry to hear this. This did help me some time ago with Xperia X, in an attempt to force Spotify to use the SD card to store its cache. Spotify found its old cache data and used it.

As you can see from the sizes, the SD-Karte is actually the phone’s internal memory.

With the update the group for Android stuff was changed from media_rw to appsupport-media_rw or a big random number. If playing with owner:group doesn’t work, change permissions with chmod -R 777 in the Android folder.

Here’s my XA2 as seen in X-plore File Manager - the second SD card is the real one:

Thank you Ahtisilli… This is exactly the situation on my 10 II with the two SD cards shown.
I tried chmod and unfortunately that also did not change the situation.

Maybe one possible trace could be the following:

Regarding that path I found the following webpage:

Might it be possible that the “real” SD card is incorrectly presented by the kernel, so that Spotify cannot recognize it? And why is the internal storage presented as SD card?

I had problens with Audible and Whatsapp. What did solve it was to stop Android support, delete 2 hidden files start Android support again. These two files inform the system that the migration is done. See

Already did that!
I have chown’ed the whole directory on the device memory. Then I deleted both files and then rebooted what brought back the users and groups to the state before I chown’ed everything =)
Thanks for your support.

I did it without a reboot - via the settings. Maybe give it one more try. Maybe the android runtime is started too early for the migration process to succeed or it gets a timeout because there is too much load during startup. One more thing I did was to delete Here Maps data which was > 1GB.

I think I have another issue…
What I did so far:

  1. try chmod 777 everything within ~/android_storage (no success)
  2. try chown 501078.501078 everything within ~/android_storage (no success)
  3. deleted everything within ~/android_storage (no success)
  4. deleted folder “Android” in SD card (no success)

Maybe some general questions:

  1. Which user and group should be set to the data on the SD card and which access rights?
  2. What is the magic behind the huge number of users (501023 etc.)?
  3. What is the difference between groups “appsupport-media-rw”, “appsupport-root”
  4. Which user, group and access rights do I need under “~/android_storage”

Seems to be a tough cookie to solve this…

Ich checked in Total Commander and under “/mnt/sdcard” there is “~/android_storage” mounted as it seems.
Also I don’t have issues with WhatsApp or other Android Apps.

This works - do stuff in root console, devel-su , sudo or my new favorite pkexec bash, browse ~/android_storage/Android/data and Android/data on the SD card (easiest with two file browsers, file-browser and nanofiles are fine). - File-browser’s bottom menu has copy path to clipboard and bash in terminal has auto-fill so there’s no need to type the long paths.

in Spotify settings, change local storage to Internal (Spotify restarts), close Spotify.

Check if there’s Android/data/com.spotify.music with files inside - not just empty directories on the SD card.
a) if the directories are empty

  • copy com.spotify.music from home to SD card and fix owner:group and permissions (777) or cp -p -R (the weird ones are correct)
  • rename the original
  • create symlink ln -s from SD card to internal storage
  • start Spotify, change local storage if changed

b) the SD card contains your data:

  • don’t copy, do everything else as above

I checked an existing ext4 on the XA2 and new ext4 and vfat (FAT32) USB stick on the 10 III.

The Android internal memory directory structure was copied to the external drive in all cases (no notification, no asking for permission). No files were (luckily) moved in my case.

1 Like

Hello Ahtisilli,

could you please do a step by step explanation with commands? especially on step " * create symlink ln -s from SD card to internal storage" i am not sure what to do exactly.

Hello again, please can someone from Jolla team give a statement if this is going to be fixed and if yes, when?