[4.2.0.19][4.1.0.24][Xperia 10II] losing cellular network after call

REPRODUCIBILITY : 100%
BUILD ID = OS VERSION : 4.1.0.24
HARDWARE : X10 II
UI LANGUAGE: german
REGRESSION:

DESCRIPTION:

Phone is losing cellular network connection after call. It does not matter if it is an incoming or outgoing call or who ends the call. This only happens when mobile data is on. It doesn’t happen when mobile data are off or only wlan on. Automatic reconnecting after 10 -30 seconds, sometimes later.

PRECONDITIONS:

German T-mobile SIM (was working error-free in my Xperia X)
Data connection on.
Connected to german telekom cellular network in germany.
SIM was working well in the phone under android before unlocking bootloader and flashing SFOS.
It’s a dual sim version with only one SIM and a sdcard.

STEPS TO REPRODUCE:

EXPECTED RESULT:

ACTUAL RESULT:

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

5 Likes

There is probably nothing wrong with the phone, let alone SFOS.

You probably start on 4G/LTE, but which cannot serve your voice call (because no VoLTE on SFOS), so you get switched over to 2G/GSM or 3G/UMTS (“CS fallback”) for the duration of the call.
Then, when you hang up, the network thinks you want back to LTE for the better data rates, so it redirects you there (“release with redirect”). These configurations are often quite static, so with suboptimal coverage overlap you can end up being told the wrong info and just dropping, having to search for the network again from scratch.

To confirm, try and place a call when already on 2G/3G and you should not see this.

4 Likes

You are right, if I prefer 3G in settings this behavior doesn’t happen. But, the same SIM in my XperiaX with SFOS 4.1.0.24, preferred 4G in settings, is working well. It switches to 2G when call is coming in and switches back to 4G after call without losing cellular network (at the same place in my flat).
So I think I can expect the same with a Xperia 10 II.

5 Likes

i can confirm the same observation and the same difference in behavior on the XA2.
On the XA2 there was a smooth transition back to 4G without overall network connection loss which is the case on the X10II with a Telekom.DE sim in my case as well.

2 Likes

I have had the same behavior on my Xperia 10 and it was annoying… Well, nice to see some persistence in SFOS. :wink:

1 Like

I tried the same with my xq-au52 having the SIM card of Telia FI in slot #1 (and an SD card).

The phone was on 4G network when the calls started. During the call, the phone indicated 3G at the top of the home view. After ending the call (at the called party or on my phone), the phone returned to the 4G network in about 6 seconds. I tested this 4-5 times.

Just to clarify, when I make or receive a call, the data connection goes down.
No problem so far.
When the call is ended, the 2G network switches on for 2s, then the entire cellular network connection breaks down.

I then have no mobile network for 20s and longer (up to 1minute).
This does not happen with a XperiaX.
I tested it today at work.

By the way, since last night the 3G network of german telekom is switched off, so it is no option to prefer 3G.

5 Likes

perhaps we can try to make a short video showing the Issue. I tried already, but I observe that Issue sometimes, but not always and had no luck so far.

I have this issue too. What is puzzling is that the network is not restored immediately even if I turn the phone off and on again, but only after a few minutes. Maybe the issue is that the operator blocks the SIM temporarily because it detects some kind of unusual activity?

1 Like

Indeed, you’re right.
And more, even if I turn on and off flightmode it takes up to 1 minute until the phone connects to cellular network.

1 Like

Same here with Xperia 10 II. My provider is Drillisch. All in All I have to switch the flightmode on and off all the time. The network connectivity is very bad! It takes a lot of time and even if 4G is shown, there is no connection to the internet… I noticed, that there is also a differenz between Android apps and sailfish apps. sailfish apps get the connection faster, while androidapps might or might not connect…

Same with Xperia 10 and german D-Netz

Same here with Xperia 10 and german Telekom and Vodafone Network. It does not make a difference if sim1/sim2 is used.
After call (not always!) it takes up to 60s until reconnect to network (mobile and voice), same for flight mode.

1 Like

Compare with my issues with XA2 (before it died).

This issue remains after the Update to 4.2 (EA) on my X 10 II.

4 Likes

I can confirm this (Xperia 10 ii, SFOS 4.2)

That’s bad, because it is very annoying to wait one minute after every call to make a new call, write a message or browsing the web… :unamused:

1 Like

Can someone with trustlevel 3 edit the tags of my bugreport from 4.0.1. to 4.1.0. please?
Thank you.

1 Like

Replying here instead of creating a separate issue: For me 2G is completely broken. I can’t use the 2G only mode, which may also explain the network issues after a call. It just tries to connect and fail in a loop. I made a short video demonstrating the issue: cloud@neko.dev

This is on an Xperia 10 II, with 4.2.0.19.

The Ubuntu Touch guys seem to have the same issue (they use the mer ofono too) and one of them shared the following workaround:

We can fix the problem with adding the precise hidl interface: transport=binder:name=slot1;interface=radio@1.1 in the ril-subscription.conf file

https://matrix.to/#/%23_oftc_%23sailfishos%3Amatrix.org/%247vankzjvjC8yFKyZN95kLN8rw0yNEwdzjRcOAJLAmvI?via=neko.dev&via=matrix.org&via=netsoj.nl&via=msg.maquis196.io

5 Likes

I have filed an internal bug on this. Thanks for reporting.

7 Likes