[4.1.0.24][Xperia XA2] jolla email not starting

After flashing the new os version jolla email is not starting any more. When I want to start the app, the system tries to start the app, but its not starting. Using the SSH connection and starting jolla-email gives the following result:
[D] unknown:0 - Using Wayland-EGL
greHome from GRE_HOME:/usr/bin
libxul.so is not found, in /usr/bin/libxul.so
[W] unknown:11 - file:///usr/share/jolla-email//email.qml:11:1: plugin cannot be loaded for module “Nemo.Email”: Cannot load library /usr/lib/qt5/qml/Nemo/Email/libnemoemail.so: (/usr/lib/libnemoemail-qt5.so.0: undefined symbol: _ZN20QMailMessageMetaData20CalendarCancellationE, version Qt_5)
import Nemo.Email 0.1
^
[W] unknown:0 - Unable to read main qml file

What can I do now?

I searched a bit in the web and found something like:

But how to find the libxul.so for SailfishOS. I’m would play a bit around, but I’m just afraid to totally break my phone. I only have one phone and need it every day…

Can anybody maybe send me his /usr/bin/libxul.so?

I tried to remove and reinstall the jolla-email and jolla-email-settings app. I used the terminal over WLAN to do this.

  • pkcon remove jolla-email
  • pkcon install jolla-email

But I didn’t see dependency’s. And jolla-email and jolla-email-settings app are still not working.

Did you really ‘flash’ the firmware or did you upgrade via OTA?
In first case I really would not see why such thing happens.
In second case I assume a not complete upgrade.
You may check / resolve via

 devel-su
 ssu re

check the output, it should say 4.1.0.24

if not, issue

 ssu re 4.1.0.24

and then

 version --dup

Or -even better- try with olf’s sfos-upgrade

2 Likes

I did an upgrade via OTA.

ssu re
gave back 4.0.1.48. → So the upgarde was not finished not properly.

So your assumption was right. There where some errors while upgrading, but I thought they were solved by rebooting the phone. The system settings app showed version 4.1.0.24. So I thought every thing is fine.

I did the upgrade using your commands. Now email app is working. Thanks a lot!!

1 Like

Do you maybe happen to have a further suggestion, for when the above does not work? Pretty please?

I have the same issue, but those commands did not help. I also tried with sfos-upgrade --verify, sfos-upgrade , pkcon (remove and install package), zypper (rm and in), and more that I do not remember, but jolla-email is still not starting, with the same command line output as per luddwig27

It’s just my fault (I messed up after what I think was an incomplete update from 4.0.1 to 4.1.0), and I am very close to resetting the device and install everything again. It’s just that no matter how thorough I be, I always seem to leave something out of my backups, and …argh!

All jokes aside, whether you have a suggestion or not, thank you.

Sorry, not really.
If ssu re claims 4.1.0.24 and version --dup (or sfos-upgrade --verify) does not find something to install all should be good.

I would try to
ldd /usr/bin/jolla-email
and see if anything suspicious comes up.

Or remove/install all packages where email is in package name. Especially nemo-qml-plugin-qt5

First, thanks peterleinchen for your help. (I’m coming through this thread)

I’ve tried to uninstall jolla-email via terminal/ssh which was successfull. Also jolla-email-settings.
pkcon install can’t find any package to install named jolla-email, jolla-email-settings or nemo-qml-plugin-qt5. Is there something wrong with the package management?

I did install mail app again via Store which works (don’t know how) but with the same problem.
(ssu re says 4.1.0.24 and version --dup doesn’t find anything to install)

Edit: Wait, the error on the command line changed… have to do further testing.
Ah, ok. I’ve Iam root it says that it can find my display. With user nemo the error stated above persists.

ldd /usr/bin/jolla-email does find all libs. :confused:
Edit2: Next try: Refreshing the package cache.
Edit3: Ok, nothing changed.

Hmm?

Try removing/installing the package
nemo-qml-plugin-email-qt5

But first check the installed version with
plcon search nemo-qml-plugin-email-qt5

Is it nemo-qml-plugin-email-qt5-0.6.17-1.22.4.jolla.armv7hl
?
And what about jolla-email, is it jolla-email-1.1.11-1.31.1.jolla.armv7hl?

Oh, whoops, I missed to click the button to send up my post :confused:

Yes, my phone has the same versions for nemo-qml-plugin-email-qt5 and jolla-email.

I’m already reinstalled nemo-qml-plugin-email-qt5 with zypper.
pkcon doesn’t find the packages if they are not installed. Strange thing.

Thank you for yor time, and apologies for my late reply. I will try to do that. If something happens, I will let you know.