[][][][] No notification sounds (ringing, SMS, alarm)

This bug was introduced to me this morning for the first time. Xperia 10 III & (Struven ketju)

I couldn’t charge my phone during the night, so I toggled flight mode on before going to bed. The battery charge remained over 50% the whole time.

  • There is a “Missed alarm” notification in the events view
  • Alarms and timers fail to provide any sound notifications
  • Settings → Sounds and feedback → Can’t play any of the notification sounds

Reboot brought all the sounds back in the system.

This is a nasty bug, because now I’m all paranoid about not waking up in time. Today I missed my train, but I could miss something far more important…

1 Like

I can advise a temporary solution, although it has become permanent for me, moving from version to version, which I use myself https://forum.sailfishos.org/t/the-sounds-of-incoming-calls-sms-notifications-disappear/9496/17?u=comsorg


I also have this issue quite often, running on Xperia 10 II.
In my case, almost every time it happens after receiving a Signal call.
Did not have time to debug it, however it looks like the problem is caused by a hang on the vibration part which blocks audio notifications as well. Seems plausible that a thread is locked or queued up with notification sounds or vibrations.

Keyboard does not vibrate on key press anymore and vibration does not work system wide. Apps like Messages crash when trying to open the pulley menu or open a messages thread as you would when you want to reply to someone.

Restarting the phone solves the problem, but a quicker fix is restarting Android App Support.
Sometimes just opening the Messages app or pressing the back button in an Android app unblocks the situation with a short vibrate and then everything works again.


Just had this no ringtone bug and restarted App. Support but it did not help.
Phonr restart did help. (aah keyboard)
I just noticed that you can check if the ringtone still works by adjusting it’s volume when in the events view. If the volume bar says ringtone volume all is ok haha good tip right ;-p
When adjusting the volume in the web browser, the bar will be labeled as volume and if you switch back to the events view or desktop view you will see it changed to ringtone volume.

1 Like

I have had the watcher running for a while now, and it detects a deadlock nicely.

In case it’s related to the audio file in question, every restart it caught was because of keira-black-ringtone.ogg.


Glad it works for you too…:slight_smile: It might not be related to what is played, but to the repeated playing in itself that has more chances of triggering the deadlock. There are cases the deadlock happens without an opened audio file, it is just that we can use this crutch to detect the condition if it is opened for more than 60 seconds…

1 Like

The file itself seems to be just fine, according to oggz validate keira-black-ringtone.ogg (and so are all the other ringtones, too)…

Still occurring for me, any word on when jolla might get a fix in for this? This bug basically requires me to keep an Android phone around.

1 Like

Did you try this one? I’m interested if it happens with this work around or not. The automated solution seems to be at the end of the discussion


[31 Mar]

I can advise a temporary solution, although it has become permanent for me, moving from version to version, which I use myself https://forum.sailfishos.org/t/the-sounds-of-incoming-calls-sms-notifications-disappear/9496/17?u=comsorg

Interestingly enough, I haven’t had this issue for quite some time (several weeks now), could some OS update have fixed it? I’m currently running

In my case I see a temporal correlation between the no sound issue and the removal of patch manager. I removed patch manager 5 days ago and still have sound. Before I had to restart once a day. Maybe this is another problem. Anyway, what I noticed further is that when the Issue occurs, it is even not possible to play music files. The start button is grayed out. Anybody seen this before?

EDIT: I have take back the part with patch manager - there is correlation. Just realized, that it happened again. And it is possible to play music files (without sound). It just takes like 10 seconds to play one second in the music player. The same applies for Videos. It’s like slow motion (without sound).
EDIT2: Please ignore my post… Here we are: [][Xperia 10 III] The sound disappears and video freeze

I just spent a long weekend on the Åland Islands, and there I had to reset the phone (Sony Xperia 10 III, with SFOS at least daily because the sounds had stopped working. Returning to mainland Finland and the capital region, I’ve not had this happen again.

Perhaps this long-standing issue is somehow related to bad radio fields and/or roaming (for some reason, Ålcom is tagged as being a roamed network, in spite of fully supporting Elisa clients at base prices)?

I also now realized that my hotel was right by the harbour, and ships (with their own mobile base stations) coming and going on a regular basis might have something to do with this.

Did you use (android) map application during the trip? Those are usually memory hungry and cause oom-events which may ruin ngdf functionality.

Yes, I did use c:geo (although it is rather conservative with memory usage, pre-loading the National Survey map makes it rather huge in any case).

I got this bad behaviour due to Android TEAMS app.
When my status was set on computer as “do not disturb” it silenced all my devices and apps (included smartphone)
Solved by checking personal accounts “current status” to be not “silenced”

Unfortunately this issue seems to persist even in SFOS (Sauna), last night during Jolla Love Day 2 I upgraded, and a couple of hours later I noticed that my sounds were gone. Resolved with the usual reboot.