[4.0.1.48] Most of android apps stopped working after update

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.0.1.48
HARDWARE (XA2, Xperia 10…): XA2 plus dual-sim
UI LANGUAGE: Swedish
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

I recently updated (OTA) from 3.4.0.24 to 4.0.1.48. The update worked smoothly, but I lost the ability to run most of android apps. I have no microG or anything, no AlienDalvik Control, no themepack support.

From the android apps I had installed (and working on 3.4) some just crash upon starting, some show e.g. white or black screen, very few works as before.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Update to 4.0.1.48
  2. Run android app that worked on 3.4 (e.g. FB Messenger)

EXPECTED RESULT:

The app starts and has the same functionality (and/or problems) as on previous SFOS release.

ACTUAL RESULT:

App crashes, freezes or in very rare instances the result is as expected.

ADDITIONAL INFORMATION:

I have checked the solutions in other questions but to no avail.
I reinstalled the AlienDalvik several times, using also the brutal way from the jolla support page.
After removing everything I wanted to reinstall apps and check if they work after reinstallation, but it turns out the Store app you can get from Jolla Store is also affected by this.
I managed to install and run Aurora Store, but it cannot download anything (however I suppose this is more a problem of Aurora, since something similar has happened before). I also tried to run APKPure app, but guess what, it doesn’t start.
What could be also interesting, there is now no install prompt when running an APK file, it just gets installed without any questions.

Here I’m including the list of android apps that I know are affected:
Messenger, Signal, Store, OLX, Allegro, Alior Mobile, PayPal, Yr, 9gag, Google Translate, APKPure

And those I know are not affected:
Aurora Store (probably), Mobilet

Did someone managed to fix this problem, or my only way is to go back to 3.4?

P.S. I realize that there are many similar questions, but since they mention slightly different problems and the provided solutions don’t work I decided to post another one.

For me, all Android Apps are working under 4.0.1.48. I am using 20+ Android Apps and all are fine (Aurora Store, F-Droid, Lufthansa, DB Navigator, Banking Apps, Firefox, MS Office, Citrix, Webex, Zoom, Jitsi, LinkedIn, Signal, Teams, Flight Simulator …)

I am using MicroG and Signature Spoofing.

I am using 4.0.1.48 on both, my XA2 and Xperia 10 without issues (except the known once, in particular hardware related issues on tzhe Xperia 10)

Therefore it is definitely not a problem of 4.0.1.48 in general

Hm, and what version of Android have you had installed before flashing to SFOS?
I remember that when I first installed, there was a warning to not update to Android 9 or it will break the SFOS installation, so I installed over Android 8.
I suppose that it could lead to some problems that now the AlienDalvik uses Android 9, and all low-level stuff is still Android 8, but I’m not sure about how are all these things interconnected.

On the XA2, I had Andoid 8. On the Xperia 10, I don’t know but I believe it came with Android 9 anyway.

OK, thanks! It seems that at least I won’t need to try to flash Android9 and then SFOS again, as it’s probably not the issue here.

I noticed that starting Android support by opening an Android App can take very loooong. Typically, I always switch off Android Support and let it start when opening an Android App. The Android Support start procedure tends to take longer and longer - until I do a reboot (typically afte about 3 or 4 weeks)

Same for me on my xa2+

Android apps which don’t work (appear shortly and switch on home with black cover):
joplin
skype
airdroid
firefox
firefox focus
xplayer
amazon music
mailo client
frdoid
apkpure
opera mini
myfritz!
powerwatch
inkspace
eufysecurity
Aptoide from jolla market (Dont work with blank cover)
adobe fill & sign
robovox
easy voice changer
camera connect
open camera
kodak pixpro remote
Canon epp
Canon print
risk

works:
fruux
fritz wlan
Netatmo weather
seyrafim keybo
Bluesmart
sony imaging edge mobile
gcrompis
BeloteAndr Free
Landrule
onirim

works with issue:
Sony headphones app (starts but don’t see that Bluetooth is activated, and want to activate it and block on it)

With canon epp android machine freeze with the message “Error: not enough storage space to install required resources.”
Furthermore under sailfish settings apps tabs some android apps seems to be not correctly link to the right place under the button "open android parameter).
Must have a little bit more time to list these.

have u try to send an audio in signal to one of your contacts??

With Zoom/Teams: yes, it worked fine

Or what do you mean?

i mean with signal app

Quick update of my attempts to fix the problem:
I factory reset the phone, which brought it back to 3.4.0, but I was unable to install anything from Jolla store, so also Android support. I was also unable to install the update to 4.0.1… Still don’t know what happened.
Then, I flashed 3.4.0 and verified that everything works as before, and did the update to 4.0.1.

I had some success as I was able to install and run Messenger! But now, after few hours I’m back to square one: Aurora starts, but can’t download anything, and Messenger just crashes upon starting.
Didn’t test other apps, as I had no time in the morning, and now I can’t install them.

I experienced quite the same after updating my XA2.
On 3.4 most of my android apps worked really well, only the one or other small issue like missing current map position in Lime app but also the ones requiring Google Play Services were working.
After update this stopped, apps like Lime were showing: Google Play Services updating…, but not showing map or some of the apps just crashed during startup, e.g. Family Link.

Also WhatsApp suddenly had issues with media, but that thing I could solve following this thread.

I searched bug reports for Play Service or microG issues but it seems that for most of the people it was working fine after update. So I thought maybe there is a problem with my initial Play Services installation and already thought about a re-flash.

Then I took a last chance and luckily I was successful and could restore all functionality I had before just by following again the same guide I used initially just adapted to new Android version 9.
So I downloaded opengapps ARM - 9.0 - nano version and followed instructions but ofc adapted to download filename. There was one error with resource Core/gmssetup-all.tar.lz which obviously is no longer contained in 9.0, this one I just ignored. After replacing system.img and restart of aliendalvik everything worked again like before update.

Single remaining issue is that GMaps still crashes during start but that’s not crucial for me atm.

HTH,
cheers

[UPDATE] Fixed by removing (or unmount it via Settings) SD card (looks like something wrong with binding of it to android).

Similar issue here.
After upgrade on 4.0.1.49 almost all android apps not able to start or dies after any clicks.
Xperia XA2+ (no gapps, no openrepos apps, clean vanilla)

Seeing in logs of logcat:

03-01 10:23:58.506 E/Parcel ( 88): Attempt to read from protected data in Parcel 0xcf4f3d90
03-01 10:23:58.508 E/Parcel ( 88): Attempt to read from protected data in Parcel 0xdd65c628
03-01 10:23:58.509 E/Parcel ( 88): Attempt to read from protected data in Parcel 0xcf4f3d90
03-01 10:23:58.509 E/WificondChannelHelper( 88): Got zero length for all channel lists
03-01 10:23:58.510 E/WificondScannerImpl( 88): Failed to start scan because there is no available channel to scan
03-01 10:24:04.512 E/Parcel ( 88): Attempt to read from protected data in Parcel 0xcf4f3d90
03-01 10:24:04.520 I/chatty ( 88): uid=1000(system) WifiScanningSer identical 1 line
03-01 10:24:04.520 E/Parcel ( 88): Attempt to read from protected data in Parcel 0xcf4f3d90
03-01 10:24:04.520 E/WificondChannelHelper( 88): Got zero length for all channel lists
03-01 10:24:04.521 E/WificondScannerImpl( 88): Failed to start scan because there is no available channel to scan
03-01 10:24:04.572 I/SurfaceFlinger( 88): ALIEN: discarding frame without app/window (system process).
03-01 10:24:04.582 I/chatty ( 88): uid=1000(system) SFThread identical 1 line
03-01 10:24:04.598 I/SurfaceFlinger( 88): ALIEN: discarding frame without app/window (system process).
03-01 10:25:18.046 I/SurfaceFlinger( 88): ALIEN: discarding frame without app/window (system process).
03-01 10:25:26.956 E/storaged( 39): getDiskStats failed with result NOT_SUPPORTED and size 0

Also easily reproduced on Store/Aptoide itself. Remove Store/Aptoide, restart device, install Store/Aptoide, start aliendalvik, run Aptoide and it dies with those messages (in a loop):

03-01 11:43:18.640 I/ActivityManager( 88): START u0 {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10004000 pkg=com.aptoide.partners cmp=com.aptoide.partners/.Start} from uid 1000
03-01 11:43:18.674 D/FakeHome( 542): onPause
03-01 11:43:18.677 I/SurfaceFlinger( 88): ALIEN: discarding frame without app/window (system process).
03-01 11:43:18.686 E/ActivityManager( 88): applyOptionsLocked: Unknown animationType=0
03-01 11:43:18.721 I/SurfaceFlinger( 88): ALIEN: discarding frame without app/window (system process).
03-01 11:43:18.722 E/libprocessgroup( 965): Failed to make and chown /acct/uid_10023: Read-only file system
03-01 11:43:18.722 W/Zygote ( 965): createProcessGroup failed, kernel missing CONFIG_CGROUP_CPUACCT?
03-01 11:43:18.722 I/ActivityManager( 88): Start proc 965:com.aptoide.partners/u0a23 for activity com.aptoide.partners/.Start
03-01 11:43:18.733 I/chatty ( 965): uid=10023(com.aptoide.partners) identical 4 lines
03-01 11:43:18.756 I/SurfaceFlinger( 88): ALIEN: discarding frame without app/window (system process).
03-01 11:43:18.816 I/SurfaceFlinger( 88): ALIEN: discarding frame without app/window (system process).
03-01 11:43:18.847 I/SurfaceFlinger( 88): ALIEN: discarding frame without app/window (system process).
03-01 11:43:18.869 I/SurfaceFlinger( 88): ALIEN: new app: com.aptoide.partners vs system
03-01 11:43:18.887 I/SurfaceFlinger( 88): ALIEN: preparing new window @0xc8dd3180-0xc8dd3180-com.aptoide.partners
03-01 11:43:18.887 I/SurfaceFlinger( 88): ALIEN: raising window: com.aptoide.partners
03-01 11:43:18.928 I/ALIEN ( 88): an application that is already active was moved to the foreground
03-01 11:43:19.036 E/AndroidRuntime( 965): FATAL EXCEPTION: main
03-01 11:43:19.036 E/AndroidRuntime( 965): Process: com.aptoide.partners, PID: 965
03-01 11:43:19.036 E/AndroidRuntime( 965): java.lang.ExceptionInInitializerError
03-01 11:43:19.036 E/AndroidRuntime( 965): at cm.aptoide.ptdev.configuration.AptoideConfiguration.getPathCacheIcons(AptoideConfiguration.java:174)
03-01 11:43:19.036 E/AndroidRuntime( 965): at com.aptoide.partners.AptoideConfigurationPartners.getPathCacheIcons(AptoideConfigurationPartners.java:94)
03-01 11:43:19.036 E/AndroidRuntime( 965): at cm.aptoide.ptdev.Aptoide.onCreate(Aptoide.java:174)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.app.Instrumentation.callApplicationOnCreate(Instrumentation.java:1154)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.app.ActivityThread.handleBindApplication(ActivityThread.java:5871)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.app.ActivityThread.access$1100(ActivityThread.java:199)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1650)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.Handler.dispatchMessage(Handler.java:106)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.Looper.loop(Looper.java:193)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.app.ActivityThread.main(ActivityThread.java:6669)
03-01 11:43:19.036 E/AndroidRuntime( 965): at java.lang.reflect.Method.invoke(Native Method)
03-01 11:43:19.036 E/AndroidRuntime( 965): at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:493)
03-01 11:43:19.036 E/AndroidRuntime( 965): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:858)
03-01 11:43:19.036 E/AndroidRuntime( 965): Caused by: java.lang.NullPointerException: Attempt to invoke virtual method ‘java.lang.String java.lang.String.replace(java.lang.CharSequence, java.lang.CharSequence)’ on a null object reference
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.Parcel.createException(Parcel.java:1956)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.Parcel.readException(Parcel.java:1918)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.Parcel.readException(Parcel.java:1868)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.storage.IStorageManager$Stub$Proxy.getVolumeList(IStorageManager.java:895)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.storage.StorageManager.getVolumeList(StorageManager.java:1169)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.Environment$UserEnvironment.getExternalDirs(Environment.java:91)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.Environment.getExternalStorageDirectory(Environment.java:481)
03-01 11:43:19.036 E/AndroidRuntime( 965): at cm.aptoide.ptdev.configuration.Defaults.(Defaults.java:19)
03-01 11:43:19.036 E/AndroidRuntime( 965): … 13 more
03-01 11:43:19.036 E/AndroidRuntime( 965): Caused by: android.os.RemoteException: Remote stack trace:
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.storage.VolumeInfo.getInternalPathForUser(VolumeInfo.java:323)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.storage.VolumeInfo.buildStorageVolume(VolumeInfo.java:344)
03-01 11:43:19.036 E/AndroidRuntime( 965): at com.android.server.StorageManagerService.getVolumeList(StorageManagerService.java:2769)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.storage.IStorageManager$Stub.onTransact(IStorageManager.java:176)
03-01 11:43:19.036 E/AndroidRuntime( 965): at android.os.Binder.execTransact(Binder.java:731)
03-01 11:43:19.036 E/AndroidRuntime( 965):
03-01 11:43:19.037 I/chatty ( 965): uid=10023(com.aptoide.partners) expire 1 line
03-01 11:43:19.054 I/chatty ( 965): uid=10023(com.aptoide.partners) expire 32 lines
03-01 11:43:19.073 I/ActivityManager( 88): Process com.aptoide.partners (pid 965) has died: fore TOP
03-01 11:43:19.073 I/Zygote ( 19): Process 965 exited due to signal (9)
03-01 11:43:19.073 W/libprocessgroup( 88): Failed to open process cgroup uid 10023 pid 965: No such file or directory
03-01 11:43:19.073 E/libprocessgroup( 88): Error encountered killing process cgroup uid 10023 pid 965: No such file or directory
03-01 11:43:19.110 I/ActivityManager( 88): Start proc 994:com.aptoide.partners/u0a23 for activity com.aptoide.partners/.Start
03-01 11:43:19.111 E/libprocessgroup( 994): Failed to make and chown /acct/uid_10023: Read-only file system
03-01 11:43:19.112 W/Zygote ( 994): createProcessGroup failed, kernel missing CONFIG_CGROUP_CPUACCT?
03-01 11:43:19.116 I/chatty ( 994): uid=10023(com.aptoide.partners) identical 30 lines
03-01 11:43:19.274 E/AndroidRuntime( 994): FATAL EXCEPTION: main
03-01 11:43:19.274 E/AndroidRuntime( 994): Process: com.aptoide.partners, PID: 994
03-01 11:43:19.274 E/AndroidRuntime( 994): java.lang.ExceptionInInitializerError
03-01 11:43:19.274 E/AndroidRuntime( 994): at cm.aptoide.ptdev.configuration.AptoideConfiguration.getPathCacheIcons(AptoideConfiguration.java:174)

I can’t confirm 100% yet, but a simple test suggests that unmounting SD card and then restarting Android support seems to fix the issue.

I think I can go without the SD card for a while and at least we know where to look for a more permanent solution :slight_smile:

Got the same issue, after the update I cant install any programs! “Insufficient Storage Space”
removed the sd card rebooted phone - not working
unmounted sd card rebooted phone - not working
disabled alien, rebooted phone , unmounted sd card again - not working

Any other suggestions besides flashing the device?

Thanks

That happened to me with Rokua (3.3.0.16). Since the first version for the XA2 I had not reflashed and probably a lot of garbage has accumulated in the storage space. After a few attempts to get the storage space free again (deleting temporary files, enlarging partitions) I still had to re-flash. It is the fastest, cleanest and most reliable way.

Oh non!!!

Well if this is what needs to be done =/
I have no choice… but to rrreflash !

thank you