[4.0.1.45] No notifications for missed calls

REPRODUCIBILITY (% or how often): always
BUILD ID = OS VERSION (Settings > About product): 4.0.1.45
HARDWARE (Jolla1, Tablet, XA2,…): Xperia X
UI LANGUAGE:
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

After the update to 4.0.1.145, notifications for missed calls are no longer shown. I can see them, when I open the caller app, but neither the notifications screen show them nor the green indicator light pulses when the screen is off.

PRECONDITIONS:

Missed phone calls

STEPS TO REPRODUCE:

  1. Have missed phone call(s)
  2. When the screen is off: No indication via the LED (no green pulse)
  3. When the screen is on: No entry on the notifications screen for the missed call
  4. Open the caller app: there the call is listed as missed

EXPECTED RESULT:

missed calls are listed on the notification screen and indicated via pulsing green LED.

ACTUAL RESULT:

no indication on notification screen nor led.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Have you also opened People app to give it the necessary permissions?

Just verified that:

  • People app opens and displays contacts (so it has permissions)
  • called my phone
  • when hanging up, the phone displayed the “call ended” screen (not sure if this was the case with SFOS 3)
  • no entry on the Notification screen, no LED inticator. Missed call is displayed in the Phone app.

I just tested this, and my XA2U works as expected; the indicator led lights up green and there’s an item in the notifications screen.

Can you test the behavior with a SMS, too? Does that behave as expected? If it does, then at least the notification system isn’t (badly) corrupted… :sweat_smile:

I guess you could try checking journalctl output for clues… I don’t really know a lot about debugging, but there are instructions available…somewhere.

SMS are working correctly (led notification and entry on the Notification screen)