[3.4.0.24] Email sync fails

REPRODUCIBILITY (% or how often): 100%
BUILD ID:
HARDWARE (Jolla1, Tablet, XA2,…): XA2
UI LANGUAGE: French
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

After the last update, the email sync is not working anymore.
It occurs with the already setup email accounts, but also when setup a new one.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. setup a new email account
  2. set the sync cycle to 5 minutes
  3. synchronize the email account
  4. wait 6 minutes to find that the sync fails

EXPECTED RESULT:

The email account sync after the time setup.

ACTUAL RESULT:

No sync.

7 Likes

Can confirm that on my XA2 with 3.4.0.24 this is still the case. My account was an existing account from 3.3.0.16 (really older) and has synced previously.
I tried a certain flow of changes: enable 2G, switch to 4G, enable wifi, enable flight modus, disable again, disable wifi, switch to 2G. All these changes did not trigger a sync.

Clicking the update button in the tile does update almost immediately.

This is a IMAP account on Linux/Dovecot. I have no Exchange support installed.

XA2 with 3.4.0.24 vs. Dovecot-Imapd works completely hassle-free over here. My server configuration is to use StartTLS with proper certificate and IMAP-Idle instead of a sync interval. Therefore there should always be an open TCP connection between client and server. To check, (as root) call

# lsof -p `pidof messageserver5` | grep TCP

This should result in a line like

  messagese 29060 nemo   42u     IPv4            3387712      0t0     TCP xperia:12345->SERVER-NAME:PORT (ESTABLISHED)

for each IMAP account configured for IMAP-Idle.

I am quite sure I don’t have IMAP idle set up :slight_smile:
Good thing that that is working. It seems the bug is more that the automatic sync doesn’t run on the expected interval.

Can confirm this as well. I have the same problem on XA2 with Exchange and Google accounts. Neither of these sync unless I manually force a sync. I have both accounts set to sync every 5 minutes. This a freshly flashed installation to 3.3.0.16 and updated to 3.4.0.24. The syncing with both accounts was working fine based on the same schedule on 3.3.0.16 before flashing. I set up the accounts on 3.4.0.24 and have deleted and set them up multiple times again. Does not help. Furthermore, the Exchange calendar does not sync at all. Google calendar sync works whenever I execute a manual sync.

I cannot sync my mails after update to 3.4.0.24

Update to my earlier message. Brief testing indicates that scheduled syncing works if I use the always up to date or the customised options. I think I was actually using the customised option also on 3.3.0.16 before flashing, so I cannot tell, if this is a regression or not. In any case, it seems that there is something wrong with the simple fixed schedule.

After a while, I confirm the @tkmikkol behaviour. The only way to make the scheduled syncing working is to use the customised options.

Thanks for reporting. We need to check the syncing, again. Sigh.

Hi. Only recently udated to 3.4.0.24. - Same issues as reported above? Any ETA for the solution?

1 Like

Hi. I´ve got an update. I discovered that for me sync works for all pre-defined sync times apart from the 5min one. - Maybe this helps. Thx.

Disclaimer:
I hope I understood the OP right: this is about no sync at all, right? Since some posts talk about scheduled automatic sync not working. So sorry if I’m off-topic.


I can’t get Jolla Email to sync at all. Upgrade to 3.4.0 happened this weekend. Before, receiving and sending mails was working fine. The only logs I could gather are from starting the email client from the terminal:

[nemo@Sailfish ~]$ jolla-email 
[D] unknown:0 - Using Wayland-EGL
greHome from GRE_HOME:/usr/bin
libxul.so is not found, in /usr/bin/libxul.so
[D] unknown:0 - Messaging :  opening database
[D] unknown:0 - "No carrier"
Loaded xulDir:/usr/lib/xulrunner-qt5-52.9.1, appDir:/usr/bin
[W] unknown:0 - void EmailAgent::activityChanged(QMailServiceAction::Activity) operation failed error code: 0 error text: "Logging in" account: 12 connection status: 0 sender: QMailRetrievalAction(0xab197680)
[W] unknown:0 - void QCopClient::connectToServer() QLocalSocket::ConnectionRefusedError "QLocalSocket::connectToServer: Connection refused"
[W] unknown:0 - void QCopClient::connectToServer() QLocalSocket::ConnectionRefusedError "QLocalSocket::connectToServer: Connection refused"

Note: both my configured mail accounts are affected and work on my desktop machine).

The only error message I get in the app is ‘Internal error’ under the accounts name. (see screenshot). Is there another place to look for logs? Can’t see anything relevant in journalctl.
Anything we can do to help debugging, @jovirkku?

Edit:
Duh, I accidentally pinged Joona Petrell instead of Jorma Virkku. :man_facepalming: Sorry!

Maybe this here reveals something?

It does! Thanks.
What I could gather: Connection to my IMAP Server works. As requested it reports capabilites to the client and e.g. lists available mail flags:

Dec 01 19:18:44 Sailfish Msgsrv[11899]: [Debug] IMAP :  "1" RECV: * CAPABILITY I     MAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE SORT SORT=DISPLAY THREA     D=REFERENCES THREAD=REFS THREAD=ORDEREDSUBJECT MULTIAPPEND URL-PARTIAL CATENATE  [...log shortened]
Dec 01 19:18:44 Sailfish Msgsrv[11899]: [Debug] IMAP :  "1" RECV: * FLAGS (\Answered \Flagged \Deleted \Seen \Draft NonJunk $Forwarded Junk followup $label4)

Further down is where it gets interesting:

Dec 01 19:18:45 Sailfish kernel: messageserver5[11899]: unhandled level 3 translation fault (11) at 0x00000008, esr 0x92000007
Dec 01 19:18:45 Sailfish kernel: pgd = ffffffc027e24000
Dec 01 19:18:45 Sailfish kernel: [00000008] *pgd=0000000045a97003, *pmd=0000000045a96003, *pte=0000000000000000
< --- other kernel messages omitted --- >
Dec 01 19:18:45 Sailfish mapplauncherd[1409]: Boosted process (pid=11899) was terminated due to signal 11
Dec 01 19:18:45 Sailfish art[13730]: [W] unknown:0 - void EmailAgent::activityChanged(QMailServiceAction::Activity) operation failed error code: 0 error text: "Logging in" account: 12 connection status: 0 sender: QMailRetrievalAction(0xab1130f0)
Dec 01 19:18:45 Sailfish invoker[13797]: error: Can't send signal 11 to application [11899]: No such process
Dec 01 19:18:45 Sailfish systemd[1355]: messageserver5.service: Main process exited, code=killed, status=11/SEGV

So as far as I can interpret this, the messageserver segfaults for some reason. But I don’t know the system good enough to find out more and debug the binary.

@jovirkku: Would the full log be of any use to you?

Edit:
Duh, I accidentally pinged Joona Petrell instead of Jorma Virkku. :man_facepalming: Sorry!

Well I feel like I’ve hijacked this topic a bit. As it turns out, my problem is in fact not related to syncing schedules.

In the end, the package for the buteo sync plugin wasn’t installed with the upgrade to 3.4.0.24. So installing that missing package got the synchronization working again. Kinda hard to find the source of the issue, though

1 Like