[3.4.0.22] Screen Rotation doesn't work in Android Apps

REPRODUCIBILITY (% or how often): Always
BUILD ID: 3.4.0.22
HARDWARE (Jolla1, Tablet, XA2,…): Xperia 10 Dual
UI LANGUAGE:
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

Display Rotation is not working for Apps in AlienDalvik anymore since 3.4 Update although it is activated in Sailfish settings and in Android settings.

PRECONDITIONS:

STEPS TO REPRODUCE:

EXPECTED RESULT:

ACTUAL RESULT:

ADDITIONAL INFORMATION:

as pointed out below the rotation works after restarting dalvik, but occurs again after a reboot of the phone.

6 Likes

It didn’t work for me at first (Xperia 10 dual SIM) until I stopped Android support, but afterwards it started working.

3 Likes

Thans @ender for the hint. Restarting Android support from settings does make screen rotation work on my XA2+

It’s still a bug. After a restart the issue is back. So one has to Stop/Start AlienDalvik after every restart.

I was really hoping that Jolla would have fixed this before SFOS 3.4 goes public, but now that I found this workaround, I can live with it.

I am fairly certain that I didn’t have this issue at first after upgrading to 3.4.0.24. I’ve only experiencing it now, weeks later.

I see the same issue with Sailfish OS 3.4.0.24
The work around specified above seems to work, but Jolla will need to fix this

I wish I could find it - can’t remember where it was posted, but there’s a fix that involves using an Android root she’ll, (lxc-attach -n aliendalvik – /system/bin/sh), and using the Settings command in Android… Anybody else remember?

Maybe try ‘settings put system accelerometer_rotation 1’ from Android she’ll. Then restart AD and test. If still stuck, go to Android display Settings and toggle auto rotation setting, then do the same in Jolla settings…

I have had it twice. Once got it fixed with restart/reboot fidling. Currently stuck with portrait. Native side works.

Found it…

https://talk.maemo.org/showthread.php?t=101015

2 Likes

I’ve had this problem for a while on my XA2 Plus. Can’t even remember when it started, might have been before 3.3 even.

Hadn’t even realized I can force Android apps to landscape by locking the Sailfish screen settings to landscape. So far my workaround was to play YouTube videos in fullscreen in Firefox, which forces all Android apps to landscape indefinitely, until I run a portrait-only Android app, which then forces all Android apps back to portrait indefinitely.

1 Like

Same problem for me using Xperia XA2 with 3.4.0.24.

No issue on my Xperia X running 3.3.016

I have this issue too after updating SailfishOS to 3.4, is Jolla going to fix this in a new release or do I need to use one of the links provided?

For now I have disabled “Start Android App Support on boot”

(Xperia XA2)

I have it also on manual start, but it’s not a guarantee that it works. I sometimes have to stop and start it again in order to make it work…

On my xperia 10 i can use the aliendialvik control from openrepros to show the android status bar. there i can toggle the autorotation off and on and then i will work again with autoration on all android apps

1 Like

Getting this on both 3.4 and 4.0 if Android App Support is set to autostart on bootup.
After phone has started Android software won’t rotate and always stays in portrait mode.
Gets fixed by restarting Android App Support.

If I disable the autostart and just start it with first usage of Android software, everything works.

So the Android App Support is probably getting started too soon on boot and cannot bind to rotation status.