XperiaX - Android apps not working

REPRODUCIBILITY (% or how often): Always
BUILD ID: 4.0.1.48 (45)
HARDWARE (Jolla1, Tablet, XA2,…): Xperia X - 5122
UI LANGUAGE:
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

All Android apps fail to start, incl. stores Store, APKPure, F-Droid etc.

Worked fine in the final 3.x release
Failed in 4.0.1.45 and 4.0.1.48

PRECONDITIONS:

None

STEPS TO REPRODUCE:

  1. Install 4.0.1.48 (45)
  2. Boot device
  3. Start random Android App

EXPECTED RESULT:

App runs.

ACTUAL RESULT:

App fails during startup execution

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

I do not have any patches, UI themer etc. installed or any of the Apps specified in the release notes which should be removed before installation.

Status shows Android subsystem correct startup.


[nemo@XperiaXDualSIM ~] systemctl status aliendalvik.service ● aliendalvik.service - Myriad Alien Dalvik Loaded: loaded (/usr/lib/systemd/system/aliendalvik.service; enabled; vendor preset: enabled) Drop-In: /usr/lib/systemd/system/aliendalvik.service.d └─01-prevent-start.conf, 50-home-mount.conf Active: inactive (dead) since Tue 2021-02-09 15:41:34 CET; 11s ago Process: 10236 ExecStopPost=/system/script/alien_ui_pid_reporter.sh stop (code=exited, status=0/SUCCESS) Process: 10219 ExecStopPost=/system/script/alien_notification_cleaner.sh (code=exited, status=0/SUCCESS) Process: 4969 ExecStartPost=/system/script/alien_ui_pid_reporter.sh start (code=exited, status=0/SUCCESS) Process: 4574 ExecStart=/system/script/start_alien.sh (code=exited, status=0/SUCCESS) Process: 3261 ExecStartPre=/system/script/alien_start_guard.sh (code=exited, status=0/SUCCESS) Main PID: 4574 (code=exited, status=0/SUCCESS) [nemo@XperiaXDualSIM ~]
[nemo@XperiaXDualSIM ~] [nemo@XperiaXDualSIM ~]
[nemo@XperiaXDualSIM ~] systemctl status aliendalvik.service ● aliendalvik.service - Myriad Alien Dalvik Loaded: loaded (/usr/lib/systemd/system/aliendalvik.service; enabled; vendor preset: enabled) Drop-In: /usr/lib/systemd/system/aliendalvik.service.d └─01-prevent-start.conf, 50-home-mount.conf Active: active (running) since Tue 2021-02-09 15:42:10 CET; 5s ago Process: 10236 ExecStopPost=/system/script/alien_ui_pid_reporter.sh stop (code=exited, status=0/SUCCESS) Process: 10219 ExecStopPost=/system/script/alien_notification_cleaner.sh (code=exited, status=0/SUCCESS) Process: 10568 ExecStartPost=/system/script/alien_ui_pid_reporter.sh start (code=exited, status=0/SUCCESS) Process: 10247 ExecStartPre=/system/script/alien_start_guard.sh (code=exited, status=0/SUCCESS) Main PID: 10255 (alien_init) Memory: 53.7M CGroup: /system.slice/aliendalvik.service ├─10255 /system/bin/alien_init ├─10279 /system/bin/sdcard -u 100000 -g 100000 -d /home/nemo/android_storage /storage/sdcard0 ├─10280 /system/bin/vold ├─10281 /system/bin/keystore /data/keystore ├─10282 /system/bin/netd ├─10283 /system/bin/installd ├─10284 zygote /bin/alien-main -Xzygote /system/bin --zygote --start-system-server ├─10285 /system/bin/drmserver ├─10286 /system/bin/debuggerd ├─10287 /system/root/sbin/healthd ├─10288 /system/genv/bin/alien_audio_server ├─10289 /system/genv/bin/alien_media_control ├─10290 /system/genv/bin/alien_resource_mgr ├─10291 /system/bin/mediaserver ├─10292 /system/genv/bin/aliensensorserver ├─10293 /system/genv/bin/alien_timezone_monitor ├─10294 /system/genv/bin/alien_bridge_server bm ap no li po nc vi pm ar ├─10295 /system/genv/bin/alien_bridge_server co ├─10296 /system/genv/bin/alien_bridge_server wi ri ├─10297 /system/genv/bin/alien_bridge_server ms fo ├─10298 /system/genv/bin/alien_gps_server ├─10299 /system/genv/bin/alien_keyboard_server ├─10300 /system/bin/rild -l libalien_native_ril.so ├─10437 system_server ├─10497 com.android.systemui ├─10512 android.process.media ├─10524 com.myriadgroup.inputmethod.remote ├─10542 com.android.phone ├─10554 com.myriadgroup.home ├─10604 android.process.acore └─10625 com.android.providers.calendar [nemo@XperiaXDualSIM ~]

Certainly cannot reproduce this myself - do you see anything relevant in the journal?

I am not a *nix guy. If there are relevant logs somewhere that I can retrieve I’ll be happy to try and retrieve them

Works for me on XperiaX in both 4.0.1.45 and 4.0.1.48.

To look at the logs it’s probably easiest

  1. Under “Settings → Developer tools” enable “Developer mode” and “Remote connection”
  2. Connect the phone to you computer using USB and select “Developer mode” when prompted
  3. ssh into the device from your computer (If you have Windows PuTTY might be the program to use)
  4. Become super user using devel-su and the same password as shown for remote connections (be cautious, you have the powers to make your phone completely unusable now!)
  5. Run journalctl -f to watch what is being written to the log
  6. Start the program in question on the phone, the log is updated in your ssh session
  7. Don’t forget to press Control-C to stop the log output and Control-D to leave super user mode before an accident happens

This is the general system log which has helped me to solve a problem (caused by myself) with the 4.0.1.15 upgrade. There is also a dedicated Android log IIRC. Don’t remember by heart now how to read it, it’s somewhere in the forums.

1 Like

OK. Thanks. Problem solved.

I previously had a version of aliendalvik-control which was removed sometime prior to upgrade. That uninstall process was apparently incomplete and a remnant remained.

I re-installed it via Storeman and then removed it via “pkcon remove aliendalvik-control” which succeeded.

Android apps now start correctly.

The log that revealed this issue looked like this:

Feb 12 00:45:39 XperiaXDualSIM apkd[5587]: Alien Dalvik is active (running)

Feb 12 00:45:39 XperiaXDualSIM alien_settings_server[3179]: Listener is set, Alien is running…

Feb 12 00:46:02 XperiaXDualSIM aliendalvik-control-proxy[5613]: [D] unknown:0 - virtual bool Adaptor::handleMessage(const QDBusMessage&, const QDBusConnection&) “com.yamaha.av.musiccastcontroller” “com_2Eyamaha_2Eav_2Emusiccastcontroller_2Eactivity_2EMainActivity” (QVariant(QStringList, ()))

Feb 12 00:46:02 XperiaXDualSIM dbus-daemon[669]: [system] Activating via systemd: service name=‘org.coderus.aliendalvikcontrol’ unit=‘aliendalvik-control.service’ requested by ‘:1.145’ (uid=100000 pid=5613 comm="/usr/bin/aliendalvik-control-proxy")

Feb 12 00:46:02 XperiaXDualSIM dbus-daemon[669]: dbus-daemon[669]: [system] Activating via systemd: service name=‘org.coderus.aliendalvikcontrol’ unit=‘aliendalvik-control.service’ requested by ‘:1.145’ (uid=100000 pid=5613 comm="/usr/bin/aliendalvik-control-proxy")

Feb 12 00:46:02 XperiaXDualSIM dbus-daemon[669]: [system] Activation via systemd failed for unit ‘aliendalvik-control.service’: Unit aliendalvik-control.service not found.

Feb 12 00:46:02 XperiaXDualSIM dbus-daemon[669]: dbus-daemon[669]: [system] Activation via systemd failed for unit ‘aliendalvik-control.service’: Unit aliendalvik-control.service not found.

1 Like