Xperia XA2 won't update to 4.1

I have been trying to us the OS updates function to update my XA2 Ultra Dual Sim to 4.1

When I go to Sailfish OS Updates I show I am on Koli Version

When I Check for Updates it tells me I am “Up to Date”

I checked my account and I am registered to receive early updates.

Is there anything else I can try other than wipe and reflash?

You could try updating from command line. Enable developer mode, then in terminal:

ssu release
version --dup

After reboot:

ssu release
version --dup


Thank you! That fixed it.

I also met this problem with my XA2. What is the reason?

It could be a simple reason like incorrect date/time on the device. Or a temporary Internet outage. Or signing in to Jolla account is not valid (somehow). Installing any app from Jolla Store would test all this (but not the date/time issue).
There must be other reasons, too.

After a failing attempt to update the OS, the file /var/log/systemupdate.log and /var/log/zypp/history might reveal the culprit.

Date and time are ok, internet connection works and i succeeded to install Pure Maps.

In the last 2 years and 3 SFOS phones in my family I really often hat the same problem. But updating by CLI, as @kaari mentioned in post #2 always worked fine.

Don’t forget to have the last 3.4 version on the phone before updating to 4.0. Please don’t skip this!
After updating to 4.0 you can update to 4.1 in a second step.

I shut down and restarted wlan and after some toying with settings, appeared the note of version The install was straightforward.
I follow Jolla Blog and Sailfish OS forum, otherwise I woudn’t know anything about the update.